[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Sam460Ex screen mode, audio and network

From: Andrea Palmatè
Subject: Re: Sam460Ex screen mode, audio and network
Date: Tue, 2 Jun 2020 18:59:13 +0200

Regard the resolution. I've seen if i call the video mode SM502 instead of SiliconMotion 502 it doesn't show the 1366x762 resolution.. that's weird..
However this is the problem i have


Il giorno mar 2 giu 2020 alle ore 18:43 Andrea Palmatè <andrea.palmate@gmail.com> ha scritto:
Hi Zoltan,
I've forwarded the message to Massimiliano Tretene. I'm waiting for his answer.
In the meanwhile i've tried to add -device ES1370 but i get no audio at all. I've also a lot of shared "memfd open() failed: Function not implemented" errors on console
Regard the video mode. I'm pretty sure that resolutions like 1366x768 should work but not unticking the "default" checkbox. They needs to be created by Screenmode program. The strange thing is that during installation i've created successfully the resolution (that however had that problem). Now with the OS even if the resolution is created i have 1024x768 twice.
I've also a problem that host mouse pointer is shown. I've read that i need to add a "tabled" device in the xml file. But where i have to create that file? Keep in mind that i'm using Ubuntu on Windows 10 via WSL and not an ubuntu machine


Il giorno mar 2 giu 2020 alle ore 16:58 BALATON Zoltan <balaton@eik.bme.hu> ha scritto:
On Tue, 2 Jun 2020, BALATON Zoltan wrote:
> On Tue, 2 Jun 2020, Philippe Mathieu-Daudé wrote:
>> Cc'ing the sam460ex maintainer.
>> On 6/1/20 8:01 PM, Andrea Palmatè wrote:
>>> It is working on an i5 laptop. I've tried to use the native screen mode
>>> 1366x768 but it has some problems. It seems a stride problem and so is
>>> not usable
> I'm not sure if it's a problem on AmigaOS side or in emulation. How to
> reproduce this? Such resolution does not show up for me in ScreenMode prefs
> so cannot be simply selected.

OK I've got it. I think you've unticked default and set a custom width.
This seems to set the width of frame buffer in memory but the mode the
card is programmed to use is still the one selected from the list so this
won't work. It seems to be either a bug in AmigaOS or the width option
does not do what you may think. Maybe ask AmigaOS developers or aCube who
wrote the driver about this. (Another known issue is that 24/32 bit modes
are not available with the AmigaOS SM502 driver which would be needed for
optimal performance with QEMU, the 16 bit mode it offers is much slower
because it has to be converted on every display update.)


Andrea Palmatè

Andrea Palmatè

reply via email to

[Prev in Thread] Current Thread [Next in Thread]