[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

QEMU black screen on booting Androidx86

From: nikhil bansal
Subject: QEMU black screen on booting Androidx86
Date: Wed, 11 Mar 2020 13:41:30 +0530

I want to run an android system on qemu. For this, I downloaded the iso file from AndroidX86 website and installed it. However, when I try to boot the installed image, qemu finds Androidx86 on /dev/sda1 and then the screen goes black and nothing happens.
I configured qemu using:
./configure --prefix=./build --enable-gprof --enable-debug-info --enable-debug --disable-pie --target-list=x86_64-softmmu,x86_64-linux-user

My qemu Invocation command is:
./qemu-system-x86_64 \
-m 2048 \
-smp 2 \
-soundhw es1370 \
-device virtio-mouse-pci -device virtio-keyboard-pci \
-serial mon:stdio \
-boot menu=on \
-net nic \
-net user,hostfwd=tcp::5555-:22 \
-display sdl,gl=on \
-hda android.img

When I enable KVM by adding the option -enable-kvm, the machine boots and everything works as expected. So, I guess in the above invocation qemu starts but for some reason the display isn't working. I tried a lot of suggestions from the internet but nothing worked. Can anyone point out the issue?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]