[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

qemu-system-arm virtio-gpu-device

From: Peter Hanzel
Subject: qemu-system-arm virtio-gpu-device
Date: Wed, 20 Nov 2019 16:57:51 +0100


I have tried to run raspbian userspace in qemu-system-arm as virt machine.
I want to use device virtio-gpu-device. I have also compiled my own
arm linux kernel where I enabled all virtio devices I could find. But
I still cannot get graphics to work. Then I changed linux kernel
(virtiogpu_kms.c) where I disabled check for VIRTIO_F_VERSION_1. Then
I restarted qemu and finally got graphics with kernel booting. But
later there I have no keyboard and no mouse.

This is qemu command I use to boot raspbian:
qemu-system-arm -M virt -m 3.5G -kernel kernel7_gpu -initrd
buster_img.img -append "root=/dev/vda1 rw video=800x600" -drive
if=none,file=buster2.raw,id=hd1 -device virtio-blk-device,drive=hd1
-netdev tap,id=net0,ifname=tap0,script=no,downscript=no -device
virtio-net-device,netdev=net0 -smp 2 -device virtio-gpu-device

I have also tried virtio-tablet-device and also compiled PCI support
to linux kernel but still cannot get keyboard and mouse to work. I
have also tried to boot FedoraARM image but no luck with

I have tried qemu on linux and also on windows.

Can I have some clues what to do next?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]