[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bridged network on macOS host (10.14.6 Mojave)

From: Karim El Chenawi
Subject: Bridged network on macOS host (10.14.6 Mojave)
Date: Mon, 28 Oct 2019 22:13:30 +0100


Has anyone managed to get bridged networking to work under Mojave? I'm using tuntap_20150118 from 
http://tuntaposx.sourceforge.net and qemu 4.1.0 from brew.

I have tried creating the bridge with:

ifconfig bridge1 create
ifconfig bridge1 addm en0 # en0 is my ethernet adapter on my mac mini connected to my local network
ifconfig bridge1 up

I also tried creating the bridge through network preferences and added en0 to it.

I start Qemu with:

qemu-system-x86_64 -accel hvf -cpu host -m 512 -hda alpine.qcow2 -device e1000,netdev=network0 -netdev tap,id=network0,script=./scripts/tap-up,downscript=./scripts/tap-down


tap-up script is:
ifconfig $BRIDGEDEV addm $TAPDEV

tap-down is:
ifconfig $BRIDGEDEV deletem $TAPDEV

If I tcpdump on the tap interface I can see DHCP requests from the VM but no replies. If I tcpdump on the bridge interface I can see the DHCP requests and replies from the DHCP server (running on the same network on a FW). I don't see any checksum errors or anything else weird, but traffic on the tap interface only flows one way, from the VM.

I asked the folks over at https://www.emaculation.com and they get bridging working with qemu-system-ppc but not with qemu-system-x86_64.

What am I doing wrong here? I can see in the forum that others have gotten bridged network to function, but with older versions of macOS. Do I need to do anything differently under Mojave?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]