[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

qemu wont load hvmloader as pc bios

From: David Lai
Subject: qemu wont load hvmloader as pc bios
Date: Thu, 26 Sep 2019 14:46:40 -0700 (PDT)

Hi  I hope this is the correct mailing list to send to.  If not please let me 
know a better channel to send this.  I havent been able to google anything.
Also let  me know if I should enable additional logging or whatever.

I have a VM under KVM which loads its kernel from the host.  This works 
fine on qemu-0.15 qemu-kvm-0.15 on fedora 16 (old)  but is failing to load
using qemu-2.6.2/qemu-kvm-2.6.2 on fedora 24 (also a bit old) and I also
tested it with qemu-kvm-3.1.1 on fedora 30 (recent) and failed too.

the VM XML looks something like this:

    <type arch='x86_64' machine='pc-0.14'>hvm</type>
    <cmdline>ro root=/dev/hda1 swap=/dev/hda2 panic=30 nousb console=ttyS0,11520
    <boot dev='hd'/>

The message I get is:
error: Failed to start domain tuna
error: internal error: process exited while connecting to monitor: qemu: could 
not load PC BIOS '/usr/lib/xen/boot/hvmloader'

I checked and the file /usr/lib/xen/boot/hvmloader is present and readable
I even tried to copy the file /usr/lib/xen/boot/hvmloader from the old
fedora16 working server and it still fails to load with the same error.

This is the the logfile on fedora30:

2019-09-26 06:42:34.474+0000: starting up libvirt version: 5.1.0, package: 
9.fc30 (Fedora Project, 2019-06-20-16:43:58, ), qemu version: 
3.1.1qemu-3.1.1-1.fc30, kernel: 5.2.7-200.fc30.x86_64, hostname: polaris
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin \
/usr/bin/qemu-kvm \
-name guest=tuna,debug-threads=on \
-S \
-machine pc-0.14,accel=kvm,usb=off,dump-guest-core=off \
-bios /usr/lib/xen/boot/hvmloader \
-m 512 \
-realtime mlock=off \
-smp 1,sockets=1,cores=1,threads=1 \
-uuid 30ef2a08-df2c-47be-9ee0-fef3fc65b26a \
-display none \
-no-user-config \
-nodefaults \
-chardev socket,id=charmonitor,fd=32,server,nowait \
-mon chardev=charmonitor,id=monitor,mode=control \
-rtc base=utc \
-no-shutdown \
-boot strict=on \
-kernel /kvm-boot/vmlinuz-2.4.20-37.7.legacy \
-append 'ro root=/dev/hda1 swap=/dev/hda2 panic=30 nousb 
console=ttyS0,115200n8' \
-device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 \
-drive file=/dev/data/tuna,format=raw,if=none,id=drive-ide0-0-0,cache=writeback 
-netdev tap,fd=34,id=hostnet0 \
rtl8139,netdev=hostnet0,id=net0,mac=00:16:36:54:40:16,bus=pci.0,addr=0x4 \
-chardev pty,id=charserial0 \
-device isa-serial,chardev=charserial0,id=serial0 \
-device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3 \
on,obsolete=deny,elevateprivileges=deny,spawn=deny,resourcecontrol=deny \
-msg timestamp=on
char device redirected to /dev/pts/3 (label charserial0)
qemu: could not load PC BIOS '/usr/lib/xen/boot/hvmloader'

"Vomunt et edant, edunt et vomant"
   Seneca (4 BC - 65 AD)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]