[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] qemu 4.0, spice and dual monitor - SOLVED

From: Frans de Boer
Subject: Re: [Qemu-discuss] qemu 4.0, spice and dual monitor - SOLVED
Date: Thu, 12 Sep 2019 13:56:12 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.8.0

On 10-09-19 09:53, Frans de Boer wrote:
On 10-09-19 08:05, Brad Campbell wrote:
On 9/9/19 4:54 pm, Frans de Boer wrote:

After some months I needed Qemu with two displays again. The last time I used it was with the latest 3.x version, without problem.

You guessed already that it did not work anymore. So, I started to add the "-display spice-app", changed to sockets after finding out that communication via TCP did also not work anymore - only to find out that this did not worked as well. In the passed I got two windows - remote viewer 1 and 2. Now I get remote viewer 1 and 1, where the second one stays blank.

Searched the internet for a full example qemu + spice, only to find the configurations for qemu 3.x.
I am using - just as before - OpenSuse Tumbleweed.

Can anybody help with this?

This works for me on Qemu 4.1.0 (and current git head). It has worked unmodified since prior to v2.9.

qemu -enable-kvm \
 -m 8192\
 -rtc base=localtime\
 -vga qxl\
 -device qxl\
 -net nic,model=virtio\
 -net tap,ifname=tap0,script=/etc/qemu-ifup,vhost=on\
 -usbdevice tablet\
 -spice port=5930,disable-ticketing\
 -device virtio-serial\
 -chardev spicevmc,id=vdagent,name=vdagent\
 -device virtserialport,chardev=vdagent,name=com.redhat.spice.0\
 -smp 3,maxcpus=3,cores=3,threads=1,sockets=1\
 -cpu qemu64,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic,hv_time \
 -drive file=/server/VM/Cadbox.raw,if=virtio,aio=threads,format=raw,cache=unsafe -boot c \  -drive file=/server/VM/Cadbox_swap.raw,if=virtio,aio=threads,format=raw,cache=unsafe \

This gives me a Windows 7 guest with dual-head.


Hi Brad,

I notice the last backslash, which suggest there is more. But do you daemonize, what command do you use to start the viewer and what viewer are you using. Maybe there is my problem?

--- Frans.

As it turns out, I used an image file for Win10, without the qxl drivers installed. Sometime ago I reused an older image, did all the updates but forgot to install the qxl driver. Ever since that time I used a single screen only. Needed now two screens again and finally found out why that did not work anymore.

--- Frans.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]