[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] qemu-system-aarch64 doesn't close after guest execute

From: Dawid Stencel
Subject: Re: [Qemu-discuss] qemu-system-aarch64 doesn't close after guest executes halt -f
Date: Fri, 6 Sep 2019 09:24:38 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.8.0


I tied the "poweroff -f" from the Linux guest system and it works as expected, but it does not need the PL061 GPIO to shutdown the system and QEMU ( I removed it from the code and poweroff still works).

So if Peter is correct that the PL061 GPIO Poweroff button is implemented as a hardware poweroff switch then it should be possible to shutdown Linux from QEMU monitor by calling:

(qemu) system_powerdown

but it does not work.

Either I do not understand the purpose of the PL061 powerdown button purpose or there is a bug in the QEMU.

Does anyone know how to use the PL061 GPIO Poweroff button ?



On 05.09.2019 15:12, Shlomo Pongratz wrote:
On Thu, Sep 5, 2019 at 4:09 PM Shlomo Pongratz <address@hidden> wrote:
On Thu, Sep 5, 2019 at 3:04 PM Peter Maydell <address@hidden> wrote:
On Thu, 5 Sep 2019 at 12:10, Shlomo Pongratz <address@hidden> wrote:
Thank you,
I've added the GONFIG_GPIO_PL061 (isn't it emulated on realview only?)
No, the 'virt' board provides a PL061, largely just for
this kind of power control purpose. I've just remembered
though that the PL061 is for power-control in the other
direction -- it allows you to shut down QEMU from outside
the VM by providing effectively an emulated power button.
The mechanism used for the VM to shut itself down should
be the PSCI power-control APIs. Check you have CONFIG_ARM_PSCI_FW
in your kernel config.

But the QEMU still doesn't exit after halt -f.
Is there a Linux config file that is known to be able to make QEMU
exit that I and use as starting point?
Yes, try the arm64 defconfig.

-- PMM

I've tried to build Linux (5.2.1) with the configuration found in
and yes Symbol: ARM_PSCI_FW [=y] in this configuration.
But still "halt -f" (busybox v1.31.0) doesn't make QEMU
(qemu-systme-aarch64 version qemu-3.1.0-9.fc30) exit.
(and again machine=virt).

Best regards,


It seems that busybox' applet poweroff -f did the trick.
Sorry for all the trouble.

best regards,


Mobica is a global software services company, delivering and enabling technologies that transform business outcomes for the leading brands in Automotive, Silicon, FinTech, Media and Telecoms. Headquartered in Wilmslow UK with offices across Europe and the US, our established technical and delivery excellence in high quality software engineering drives success for our multinational customers on every continent, every day. Find out more at Mobica.com <https://www.mobica.com>

Mobica Limited is a limited company registered in England and Wales with registered number 05169596 and VAT registered number 223837508. Our registered office is at Crown House, Manchester Road, Wilmslow, Cheshire, SK9 1BH, UK. This message is intended solely for the addressee(s) and may contain confidential information. If you have received this message in error, please send it back to us, and immediately and permanently delete it. Do not use, copy or disclose the information contained in this message or in any attachment. Mobica complies with all requirements of GDPR and other relevant data protection law. You can view our Privacy Policy at https://mobica.com/privacy-policy/ <https://mobica.com/privacy-policy/>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]