[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] [Qemu-arm] Ubuntu installation shows "No network inte

From: Peter Maydell
Subject: Re: [Qemu-discuss] [Qemu-arm] Ubuntu installation shows "No network interfaces detected"
Date: Tue, 16 Apr 2019 16:42:21 +0100

On Tue, 16 Apr 2019 at 16:33, Da Zhang <address@hidden> wrote:
> This is my gem5 simulation output. My goal is using qemu-system-aarch64 to 
> create an ARM disk image for my gem5 simulations, since qemu provides a 
> better solution to modify the image (e.g., apt-get install) for different 
> purposes.
> Firstly, I created a qcow2 image and used the qemu-system-aarch64 command 
> shown in the previous emails to install Ubuntu.
> Secondly, I converted the qcow2 disk image to raw format and rebooted from 
> the raw disk image via qemu-system-aarch64 (without cdrom) again to make sure 
> the Ubuntu system work.
> Thirdly, I put gem5's m5 executable in the guest system's /sbin/ and create 
> gem5.service, and reran qemu to make sure the disk image still work after 
> modifications.
> Finally, I ran my gem5 simulation using the disk image and encountered the 
> kernel panic. The linux kernel used in my gem5 simulation was built from 
> repository "https://gem5.googlesource.com/arm/linux"; branch gem5/v4.4 for 
> linux kernel version 4.4.
> I am not sure if gem5 support vda or not. Since both our X86 disk image and 
> the official ARM disk image used sda, I thought I might give it a quick try. 
> That's why I asked how to run qemu-system-aarch64 with sda. I tried -hda and 
> -cdrom, but qemu-system-aarch64 didn't recognize the disk image and the iso. 
> I also tried to use device like scsi-hd, but qemu complained about no SCSI 
> bus.

Now I'm really confused. Why have you put a gem5 executable
into the *guest* system's filesystem?

Anyway, it sounds like:
 * QEMU is working fine
 * you've created a disk image
 * you're trying to run GEM5 with that disk image and some other
   kernel, but it isn't doing what you expect

If so, then you'd be better off asking GEM5 people what the right
GEM5 command line is to pass a disk image to it. This will be
completely unrelated to what QEMU command line options you need
to get QEMU to treat a disk image as scsi vs virtio.

-- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]