[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] Query regarding transparent passing of L2 headers with QE

From: Ramadoss, Kumar 1. (Nokia - IN/Chennai)
Subject: [Qemu-discuss] Query regarding transparent passing of L2 headers with QEMU sessions
Date: Tue, 26 Mar 2019 04:55:16 +0000

Hi *,

This query is regarding transparent passing of L2 headers with QEMU session. I 
have started a QEMU session from my Centos Linux to start a virtual machine. 
Guest environment is started and running. Typically, QEMU creates a tap 
interface (say tap0) in the Centos Linux for which there would be a 
corresponding interface in the guest environment (say eth0). If I am sending 
packet from say a traffic generator to tap0, then this packet would be 
available at eth0 also in the guest environment for processing.

Problem which I am facing is that if I am sending a packet with a VLAN tag 
[meaning with dst mac, src mac, VLAN tag [priority bits + VLAN] + IP headers on 
top of that], this packet is received as it is in the eth0 interface (in guest 
environment), but the only difference which i see is that if the priority bits 
is set to some (other than 0), then when it is received on the eth0 interface 
it is still received with priority bit as 0. But the VLAN is received as it was 
sent from the traffic generator.

I want to know whether QEMU is doing something that this priority bits is 
getting lost (filled with 0. Or is it some settings requried in QEMU for this 
be received transparently in eth0 interface in the guest environment? Or is 
this has nothing to do with QEMU?

Because, I tried the same without any QEMU by just have veth pairs and sent the 
packet from the generator to one interface in the pair, priority bits are 
received on the other interface in the pair as it is.

Is this a known bug in QEMU? B'cos I tried this with Ubuntu linux distribution 
as the VM and I still see that the priority bits are not passed transparently 
to the guest.

For eg. Following was the command used with QEMU for starting ubuntu:

/bin/qemu-system-x86_64 -m 2048 -boot d -enable-kvm -smp 3 -netdev 
tap,id=network1,ifname=qemu-test,script=no,downscript=no -device 
e1000,netdev=network1,mac=00:00:00:01:0C:77 -hda testing-image.img -cdrom 

It would be helpful, if some insight is provided for the above query.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]