[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] PCI error running qemu to emulate sparc64

From: Dennis Luehring
Subject: Re: [Qemu-discuss] PCI error running qemu to emulate sparc64
Date: Wed, 26 Sep 2018 05:51:38 +0200
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:60.0) Gecko/20100101 Thunderbird/60.0


i've followed (years ago) this blog to install debian wheezy on sparc64, works 
with Debian 7.11 (newer debians removed sparc support) - beware: its awfully 
slow, but it works/runs
then i tried NetBsd with the same (working) configuration but that does not 
boot at all - i've build the qemu source myself to have the latest version that 
time, maybe NetBsd works now

your questions:


KVM does speedup virtualized x86 code - so makes no sense with sparc64

for the rest - follow this blog: 
http://tyom.blogspot.com/2013/03/debiansparc64-wheezy-under-qemu-how-to.html - it works 
and after that you've got a "working" hardware configuration to play with
when switching to NetBsd

Am 25.09.2018 um 23:15 schrieb Rocky Hotas:
I am new both to QEMU and to the mailing-list. Hoping this is the right
place to ask.
I am running QEMU on a Linux Ubuntu 18.04 amd64 host. I would like to create
and run a sparc64 VM with NetBSD. Starting from this guide,


I adapted it as follows:

$ qemu-img create -f qcow2 disk_sp.qcow2 15G
$ wget http://cdn.netbsd.org/pub/NetBSD/NetBSD-7.1/images/NetBSD-8.0-sparc64.iso

$ qemu-system-sparc64 -m 2048 -enable-kvm \
     -drive if=virtio,file=disk_sp.qcow2,format=qcow2 \
     -netdev user,id=mynet0,hostfwd=tcp::7722-:22 \
     -device e1000,netdev=mynet0 \
     -cdrom NetBSD-8.0-sparc64.iso

First, this error is generated:

qemu-system-sparc64: -machine accel=kvm: No accelerator found

Is it normal?
Then, erasing the `-enable-kvm' option:

qemu-system-sparc64: -device e1000,netdev=mynet0: PCI: no slot/function 
available for e1000, all in use or reserved

Even without `-cdrom' and without `-device':

$ qemu-system-sparc64 -m 2048 \
     -drive if=virtio,file=disk_sp.qcow2,format=qcow2 \
     -netdev user,id=mynet0,hostfwd=tcp::7722-:22
qemu-system-sparc64: -drive if=virtio,file=disk_sp.qcow2,format=qcow2: PCI: no 
slot/function available for virtio-blk-pci, all in use or reserved

Why does it always generate this error? What can be wrong?
Thank you,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]