[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] console output with -nographic on Windows

From: Thomas Huth
Subject: Re: [Qemu-discuss] console output with -nographic on Windows
Date: Mon, 17 Sep 2018 13:43:32 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.9.1

On 2018-09-17 13:26, Brendan Simon (eTRIX) wrote:
> I've been trying to use the following GNU MCU Eclipse QEMU releases to
> do unit tests for ARM Cortex binaries.
> https://gnu-mcu-eclipse.github.io/qemu/
> https://gnu-mcu-eclipse.github.io/qemu/releases/
> I compiled the very simple semi-hosting hello world sample in the gcc
> arm installation (from ARM download site).  It's a basic `printf("Hello
> world!");`
> It runs ok on the Mac.  i.e. displays "Hello world!" on the terminal
> that I run qemu from.
> However the same command line and exact same binary does not show any
> output when run on a Windows box (Win 10).  I tried from MSYS2 bash
> shell and Windows Command Prompt, and both show no output.
> A bit of googling suggests that it displaying console output just
> doesn't work on Windows.
> Is that really true?  Why can't Windows output to stdout?  Surely it's
> technically possible, and not too difficult?  Surely there must be a way
> to get stdout working Windows.
> What magic do I have to do to get this working?

Is your QEMU binary using SDL1.2 ? In that case, it's likely that SDL
redirects stdout into a file. Try a binary that is linked against SDL2
instead - as far as I know, SDL2 does not do this redirecation anymore.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]