[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] unstable qemu under Ubuntu (on Windows)

From: Fabrizio Caruso
Subject: Re: [Qemu-discuss] unstable qemu under Ubuntu (on Windows)
Date: Wed, 5 Sep 2018 08:15:52 +0000


Indeed I am using Windows subsystem for Linux where I run qemu.
The binaries are OK if run outside of Windows.

What is puzzling is that quemu does run well on some binaries under Windows 
subsystem for Linux.
Is this a bug? Or are the random core dumps an expected behavior because there 
is no support for nested virtualization?

Anyway, how can I run ELF Linux binaries under Windows?
Should I try a real virtual enviroment, e.g., VirtualBox? Does qemu run under 


De : Peter Maydell <address@hidden>
Envoyé : mardi 4 septembre 2018 21:25
À : Fabrizio Caruso
Cc : address@hidden
Objet : Re: [Qemu-discuss] unstable qemu under Ubuntu (on Windows)

On 4 September 2018 at 19:07, Fabrizio Caruso
<address@hidden> wrote:
> I am building linux ppc/68k/386 ELF binaries and I would like to run them 
> wihout having to put them into virtualized disks. Can I do it?
> It seems I can under Ubuntu (on Windows 10) but I often get core dumps (not 
> always).
> My qemu version is
> "
> qemu-ppc version 2.11.1(Debian 1:2.11+dfsg-1ubuntu7.4)
> Copyright (c) 2003-2017 Fabrice Bellard and the QEMU Project developers
> "
> On some binaries qemu works on other it crashes badly:
> address@hidden:/mnt/c/Retro/CROSS-CHASE$ qemu-i386 build/FULL_linux386.exe
> qemu: uncaught target signal 11 (Segmentation fault) - core dumped
> Segmentation fault (core dumped)
> address@hidden:/mnt/c/Retro/CROSS-CHASE$ qemu-ppc build/FULL_linuxppc.exe
> qemu: uncaught target signal 11 (Segmentation fault) - core dumped
> Segmentation fault (core dumped)
> address@hidden:/mnt/c/Retro/CROSS-CHASE$ qemu-m68k build/FULL_linux68k.exe
> qemu: uncaught target signal 4 (Illegal instruction) - core dumped
> Illegal instruction (core dumped)
> What am I doing wrong?

That path suggests that maybe you're running QEMU under the Windows
Subsystem for Linux. Are you? If so, the first thing to do is to try
running on a native Linux host. That would let you rule out bugs in WSL.

Otherwise, either your guest process itself has a bug (ie it is causing the
segfault/coredump, which QEMU is just passing along), or there is a QEMU bug.
Do the binaries work correctly when run on native PPC/i386/m68k Linux?

I'm pretty sure our m68k emulation is currently incomplete (it definitely
was back for the 2.11 release) -- it was originally written to support
Coldfire CPUs, not classic m68k. So I'd skip that one for now.

You might start by testing with the latest QEMU version. If that fails
then you could try putting together a test case with complete reproducer
instructions and file a bug report against QEMU.

> I cannot find a Windows qemu version. I only find qemu-system, which is not 
> what I want.

The linux-user QEMU binaries exist only for Linux hosts, because they simply
pass the guest process's system calls through to the host kernel. They cannot
work on Windows or OSX, because those OSes do not provide the same syscalls.

-- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]