[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] touch screen emulation in android-x86

From: Günter Merz
Subject: [Qemu-discuss] touch screen emulation in android-x86
Date: Mon, 13 Aug 2018 12:02:12 +0000
User-agent: Internet Messaging Program (IMP) H6 (7.0.0-git)


I'm new, but excited to use qemu.

The latest android-x86 Oreo RC1 attached a script to run android-x86 in qemu.
This is exactly what I've been wanting to do for a while. I had tried to run android-x86 in VirtualBox before but performance was abysmal.
In qemu performance seems very good on first glance.

My issue starts here:
I have a touch screen on my laptop and would like to use it in android-x86.

On the host, the touch- creen is a PCI device.
I tried options '-usb -device usb-tablet' and '-device virtio-tablet-pci'.
Both give me access to the touch screen but on both, the touch screen behaves like a mouse - the opposite of what the qemu tablet option describes.

In android, calling 'getevent' on the input device yields a device with the events of a mouse, not of a tablet.

I tried to make android-x86 reinterpret the mouse events into touch events by modifying an .idc according to this guide


but I didn't achieve any improvement. I couldn't find out whether I did it correctly though.

The android emulator, which seems qemu based, seems to at least achieve single-touch events. The only evidence I found that multi-touch events are translated into the emulator is via a physical device or the SdkController.

If I understood correctly, VirtualBox is also somehow based on qemu and via VirtualBox, I can operate my touch screen correctly.

Has anyone here tried to achieve what I want?

Does anyone spot any blatant mistakes I made?

Or is it actually common knowledge that what I want to do is not possible in qemu?

Thanks in advance.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]