[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] Disk write problems with different DOSes + phantom keystr

From: stecdose
Subject: [Qemu-discuss] Disk write problems with different DOSes + phantom keystrokes
Date: Wed, 4 Jul 2018 16:48:41 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.8.0


i have a weird problem with different DOSes. Some read and write accesses to disk cause errors. I tell it "retry" a few times and it works.

I have attached screenshots.

I have tried these DOSes:

* IBM PC-DOS 5.02 (English)

* IBM PC-DOS 2000 (German)

* MS-DOS 5.0 (English)

* MS-DOS 6.22 (English, German)

I also tried PTS-DOS 6.5 (German), but this one almost always gets phantom keystrokes, like:

ccdd c:\ptssddoos

(cd c:\ptsdos)

I am using qemu 2.8.1 (debian stretch, from repo) and I am invoking qemu like this:

qemu-system-i386 --enable-kvm -M isapc -cpu 486 -m 32 -soundhw sb16,pcspk,adlib -serial stdio -no-acpi -no-hpet -net noneĀ  -hda hdimage_256M.raw

The disk image is a 256MB raw disk image.

I disabled kvm for testing, but didn't work. I tried PCI-Pentium, more or less RAM, no sound, ...

Host computer ist a i5 520m, 2GB RAM, debian stretch.

I tried to find a solution for both of these problems, but couldn't find :(

Maybe someone here can help me.

Thank you,


Attachment: qemu_dos_err000.png
Description: PNG image

Attachment: qemu_dos_err001.png
Description: PNG image

reply via email to

[Prev in Thread] Current Thread [Next in Thread]