[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] Adding an additional console to the VM on x86

From: Jintack Lim
Subject: Re: [Qemu-discuss] Adding an additional console to the VM on x86
Date: Fri, 16 Feb 2018 08:32:48 -0500

On Fri, Feb 16, 2018 at 1:38 AM, Thomas Huth <address@hidden> wrote:
> On 16.02.2018 04:45, Jintack Lim wrote:
>> Hi,
>> I was able to add an additional console to the VM on ARM like this,
>> -chardev socket,server,host=*,nowait,port=6666,telnet,id=mychardev0
>> -device virtio-serial-device
>> -device virtconsole,chardev=mychardev0
>> But the same command gave an error on x86.
>> qemu-system-x86_64: -device virtio-serial-device: No 'virtio-bus' bus
>> found for device 'virtio-serial-device'
>> I wonder what would be the correct option to do that on x86?
> AFAIK the "-device virtio-*-device" only works on ARM (with
> virtio-mmio). On x86 and other platforms, please try to use "-device
> virtio-serial-pci" instead, since x86 uses the virtio-pci transport.

Thanks, Thomas.

I tried virtio-serial-pci. I was able to boot the VM without an error.
I ran telnet like 'telnet localhost 6666' in the host, but it didn't
seem like printing anything or taking any input.

$telnet localhost 6666
Connected to localhost.
Escape character is '^]'.

I'm using QEMU v2.11.0


>  Thomas

reply via email to

[Prev in Thread] Current Thread [Next in Thread]