[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] Confusing kernel behaviour with QEMU Pi emulator

From: Mark Green
Subject: [Qemu-discuss] Confusing kernel behaviour with QEMU Pi emulator
Date: Thu, 11 Jan 2018 16:37:28 +0000


I am trying to use the QEMU based Raspberry Pi configuration at
https://sourceforge.net/projects/rpiqemuwindows/ to simulate bare metal
development on the Pi, but having some weird difficulties.

First of all, I tried assembling an ARM program and placing it on the
provided disk image in the kernel.img file. However, the Pi emulator by
default launches with the command line option "-kernel kernel-qemu" which
seems to ignore this, as even when kernel.img was changed it booted Linux
in the same way.

So I tried putting my arm program's assembly file into the command line in
the parameter to "-kernel", and QEMU started but nothing happened. So I
used -S and the monitor to try to figure out what was happening. However on
running, it appeared that the program was not loaded at $8000 (as the
documentation claimed would normally be the case on the Pi) as there was no
code there, and the starting PC (R15) was set to $0, where there was no
code either.

So when using an alternative "kernel" in this way, where is it actually

Also, removing the "-kernel" option from the command line, which I hoped
would cause it to use the kernel.img file from the virtual disk, instead
caused QEMU to simply "fall out" with no error message or suggestion as to
what had gone wrong. I did encounter this before as it happened when
another process had the virtual disk open, but even after closing
everything else, it still falls out without explanation. Is there any
reason for this and is the lack of an error message a bug which could be


reply via email to

[Prev in Thread] Current Thread [Next in Thread]