[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] virt-install and bridged interfaces

From: Dan MacDonald
Subject: [Qemu-discuss] virt-install and bridged interfaces
Date: Tue, 28 Nov 2017 18:57:37 +0000

Hi qemu list

I have a CentOS 6 disk image I created with Packer which I would like
to use with a network manager bridged network interface (virbr0) under

I can run the image under qemu/KVM with working bridged networking
using a command such as this:

qemu-system-x86_64 -enable-kvm -cpu host -m 1024 -net nic,model=virtio
-net bridge,br=virbr0,helper=/usr/lib/qemu/qemu-bridge-helper -drive

Despite the two -net options used, only one net interface is present
on the VM and it gets assigned a local IP which I can ping from my
host. This is what I'm hoping to achieve but I have not been able to
so far when importing the image into libvirt using virt-install. I
have been trying many variations upon a command like this:

virt-install -n centos6test -r 1024 --connect qemu:///system
--os-type=linux --cpu host --os-variant=rhel6 --disk
--network bridge=virbr0 --vnc --noautoconsole --import

I have also tried defining a bridged network with virsh, like so:

  <forward mode="bridge"/>
  <bridge name="virbr0"/>

Then importing that with `virsh net-define` and setting the network
device to use that virsh network. I've also tried using two net
devices, one bridged and one not etc etc but nothing has worked for me
so far in that none of the interfaces ever get assigned an address
after being imported into libvirt and started with virt-install whilst
everything works fine if I just run the image with the first qemu
command I gave.

I would like to be able to control my VM with virsh but this issue is
stopping me. I'm running Ubuntu 17.10 on the host.

Thanks for your help


reply via email to

[Prev in Thread] Current Thread [Next in Thread]