[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] qemu-system-aarch64, cloud-init, Ubuntu Cloud Image - He

From: Aimee Ukasick
Subject: [Qemu-discuss] qemu-system-aarch64, cloud-init, Ubuntu Cloud Image - Help
Date: Mon, 27 Nov 2017 20:21:58 -0600
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.4.0

Hi. Newbie here. I am trying to access an Ubuntu image running in

I'm following this guide:

Host OS: Linux 4.4.0-101-generic #124-Ubuntu SMP x86_64 x86_64 x86_64

qemu-system-aarch64 version: QEMU emulator version 2.5.0 (Debian

cloud image:
kernal: QEMU_EFI_1602.fd

I did manage to get the cloud image deployed with qemu. The problem is I
can't access the image because whatever cloud-init qemu is using is
*not* accessing the "user-data" data in the my-seed.img, where my user
and ssh key are defined. I also defined a custom final_message that's
not being displayed.

my-user-data, which is written correctly to user-data in my-seed.img:
# cloud-config

# Add users to the system. Users are added after groups are added.
  - default
  - name: aimeeu
    lock_passwd: False
    sudo: ['ALL=(ALL) NOPASSWD:ALL']
    groups: sudo
    shell: /bin/bash
      - <my public ssh key>

  list: |
  expire: False

# final_message
# default: cloud-init boot finished at $TIMESTAMP. Up $UPTIME seconds
# this message is written by cloud-final when the system is finished
# its first boot
final_message: "*****THE SYSTEM IS FINALLY UP after $UPTIME seconds"

address@hidden:~/dev/QEMU-arm64$ cloud-localds my-seed.img my-user-data
address@hidden:~/dev/QEMU-arm64$ qemu-system-aarch64 -smp 2 -m 8192
-M virt -bios QEMU_EFI_1602.fd -nographic \
>        -device virtio-blk-device,drive=image \
>        -drive
if=none,id=image,file=xenial-server-cloudimg-arm64-uefi1.img \
>        -device virtio-blk-device,drive=cloud \
>        -drive if=none,id=cloud,file=my-seed.img,format=raw \
>        -netdev user,id=user0,hostfwd=tcp::2222-:22 -device
virtio-net-device,netdev=user0  \
>        -cpu cortex-a57

The output is a bunch of gibberish until finally:
Ubuntu 16.04.3 LTS ubuntu ttyAMA0

ubuntu login: [  160.981732] cloud-init[1037]: Cloud-init v. 17.1
running 'modules:config' at Tue, 28 Nov 2017 01:33:39 +0000. Up 158.09
[  171.189035] cloud-init[1187]: Cloud-init v. 17.1 running
'modules:final' at Tue, 28 Nov 2017 01:33:49 +0000. Up 167.86 seconds.
[  171.192742] cloud-init[1187]: Cloud-init v. 17.1 finished at Tue, 28
Nov 2017 01:33:52 +0000. Datasource DataSourceNoCloud
[seed=/dev/vda][dsmode=net].  Up 170.93 seconds

Ubuntu 16.04.3 LTS ubuntu ttyAMA0

The default final_message is displayed rather then my custom one. I also
cannot log in via the displayed login prompt nor via ssh. I've tried
various options and really need some help.

Does anyone know why the cloud-init that qemu is using is not reading
the user-data that's in the my-seed.img file that I passed to qemu? I've
tried in vain to find logs and to get qemu to output to a log file using
the -D option.
Any help of any kind is greatly appreciated.

Thanks in advance!


Aimee Ukasick
Open Source Engagement Cloud Native, IoT, ONAP

reply via email to

[Prev in Thread] Current Thread [Next in Thread]