[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] s390x user-mode working example

From: Alex Kashchenko
Subject: [Qemu-discuss] s390x user-mode working example
Date: Thu, 23 Nov 2017 21:00:50 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.8.0


I am trying to build qemu-s390x-user static binary to run a hello-world program cross-compiled with gcc-s390x-linux-gnu on linux_x86_64.

I am building qemu with:

./configure --static --disable-werror --target-list=s390x-linux-user

and running example with:

QEMU_STRACE=1 ./s390x-linux-user/qemu-s390x path/to/s390x-hello

I tried latest git and a number of v2.x releases without success. Can see either hang (on first brk call) or various errors for newer versions and "Illegal instruction" for older ones. Tried on ubuntu 16.04 and 17.10 without success.

The same steps worked for me for ppc64le hello-world.

Any help on this is highly appreciated.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]