[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] Any successful story of debugging linux 4.13 with qemu 2.

From: Natale Patriciello
Subject: [Qemu-discuss] Any successful story of debugging linux 4.13 with qemu 2.10 and gdb 8.01?
Date: Fri, 15 Sep 2017 15:08:10 +0200

Hello all,

As the title says, any of you have successfully tried to debug Linux
4.13 with QEMU? My problem is that it is not possible to break (even
with hbreak) in any function of the kernel, from the most used
(schedule or spin_lock) to the most obvious (uptime_proc_show when
/proc/uptime is read).

To be more specific, QEMU correctly stops if I put "-s -S" on the
command line, and perfectly continue the execution of the kernel when
I connect gdb using 'target remote :1234'. However, any breakpoint is
simply ignored.

I have followed any possible tutorial and any possible answer to
similar user questions. I also tried to do the same on a 16.04 version
of Ubuntu, but the result is always the same. In particular, I have
using both a busybox image and a raw filesystem image of Archlinux.

There is any known problem in debugging Linux? How can I "debug" this
debug process?

Thank you!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]