[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] qemu 2.9 Windows 10 VM restart issues follow-up

From: Sam Varshavchik
Subject: [Qemu-discuss] qemu 2.9 Windows 10 VM restart issues follow-up
Date: Wed, 26 Jul 2017 21:22:19 -0400

I first mentioned this a few weeks ago. An upgrade from Fedora 25 to 26 updated qemu 2.7 to qemu 2.9. I had two Windows 10 hosts that went this upgrade path.

After the upgrade, the Windows 10 guests started experiencing sporadic issues when they initiate a reboot from within the guest VM. Most of the time the reboot drops into some kind of a recovery mode. After "preparing automatic repair", Windows 10 then claimed that no restore points were found, and all attempts to coax it to boot, from that point failed.

With the first guest, I initially thought that it was hopelessly borked, and I reinstalled it from scratch. But it became soon apparent that I was fooled into doing that, this was completely unnecessary. The guest was fine. Doing a force-off of the VM, once it enters the automatic repair mode and a cold start, resulted in a perfectly normal boot. Or, instead of rebooting in the first place, having Windows 10 shut itself down, then starting the VM back up, also resulted in a perfectly normal boot.

Occasionally, a reboot worked without going into recovery mode. But most of the time a reboot ends up going into automatic recovery.

So, the update is that I've observed this pattern consistently for the last couple of weeks. Today, one of the guests wanted to install the creator's update. The first reboot worked, and it started churning through the update. After half an hour of grinding through the update, there was another reboot. No errors were overtly shown; but after some period of time, I was informed that it was "Restoring previous version of windows", and eventually I ended up back where I started.

Not sure what other troubleshooting I can do here. There was nothing particularly unusual about the VM. A Spice display, raw hard drive, nothing fancy. No extra device drivers of any kind, are installed. I guess I'll wait and see how the other guest handles the creator's update.

Attachment: pgpiLqy832v4x.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]