[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] WinXP Guest: New hardware found - VGA controller

From: Joe
Subject: Re: [Qemu-discuss] WinXP Guest: New hardware found - VGA controller
Date: Thu, 26 Jan 2017 00:18:53 +0100

On Wed, Jan 25, 2017 at 3:56 PM, Alberto Garcia <address@hidden> wrote:
> On Wed, Jan 25, 2017 at 03:43:23PM +0100, Joe wrote:
>> > If it worked with an earlier version and now you find that the
>> > guest is detecting new hardware, try forcing the emulation of a
>> > machine from an older version of QEMU.
>> >
>> > For example:
>> >
>> > qemu-system-i386 -M pc-i440fx-1.6 -m 2G ...
>> >
>> > Type 'qemu-system-i386 -M ?' for a complete list.
>> >
>> I tried various "machines" from that list but the issue still
>> persists.
>> I opened devices manager of XP and selected the yellow question mark
>> relate to the "video controller (VGA compatible)".  Under details
>> tab, ID hardware, I can read the following code:
>> PCI\VEN_1234&DEV_1111&SUBSYS_11001AF4&REV_00
> That's the QEMU Standard VGA (PCI ID 1234:1111):
> https://github.com/qemu/qemu/blob/master/docs/specs/standard-vga.txt
> If you use that '-M pc-i440fx-1.6' and omit '-vga std' then you'll get
> a Cirrus card instead.
> Berto

Thanks for your hint! That solved!  :D

Anyway the issue was related to a misunderstanding of qemu man page:
 -vga type
           Select type of VGA card to emulate. Valid values for type are

               Cirrus Logic GD5446 Video card. All Windows versions
starting from Windows 95 should recognize
               and use this graphic card. For optimal performances,
use 16 bit color depth in the guest and
               the host OS.  (This one is the default)

So I thought that without an explicit "-vga" option, qemu emulated the
default one: "Cirrus Logic GD5446". But I noticed the "standard" qemu
video card instead, the same obtained with "vga -std".
So I need to just specify "-vga cirrus" to solve the issue and run Win
XP with a perfectly recognized Cirrus video card.

The issue persist with the option "-vga std" or without -vga option
specified (as I reported above it seems qemu use "std" as default, not
cirrus) . Anyway I think that standard video card hasn't a real ID
hardware, so XP recognizes it as an un-managed device. But it seems to
work properly and the solution could be just ignore the "new hardware
found" message at boot.

I noticed "-vga std" seems better than "cirrus", due to a higher
resolution: I'm trying to use autocad under XP virtualized by qemu and
high resolution would be appreciated.

What could be the best options for to optimize VGA performances of XP with qemu?

My Qemu VM is located in my local system (I have all on an SSD device)
not remotely.

Thanks again for your tips!  :)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]