[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] Fail to open software in kvm guest

From: John Y.
Subject: [Qemu-discuss] Fail to open software in kvm guest
Date: Sun, 13 Nov 2016 10:34:18 +0800

I can not open my software in my windows server 2008 kvm guest.
I can find the process in task manager when I open my software and it disappear after 2 or 3 seconds.
The process will not disappear when I pin the vcpu to a physical cpu, but I still cann't open my sofeware.
I had found 3 softwares work like this case. They all work fine in the physical server.
I had tried windows server 2008, windows server 2003 and windows 7.
I had tried to use host-passthrough, host-model and qemu64 as cpu model.

It this a bug or I uesd in a wrong way?

Qemu version:
# /root/qemu25/qemu/x86_64-softmmu/qemu-system-x86_64 --version
QEMU emulator version, Copyright (c) 2003-2008 Fabrice Bellard

My libvirt:
<domain type="kvm" xmlns:qemu="http://libvirt.org/schemas/domain/qemu/1.0">
    <boot dev='hd'/>
    <boot dev='cdrom'/>
  <clock offset="localtime"/>
  <vcpu current="1">1</vcpu>
  <cpu mode="host-passthrough"/>
    <disk device="disk" type="file">
      <driver name="qemu" type="qcow2"/>
      <source file="/root/vm/disk.qcow2"/>
      <target bus="virtio" dev="vda"/>
    <disk type='file' device='cdrom'>
 <source file=''/>
 <target dev='hdc' bus='ide'/>
    <serial type="pty">
      <source path="/dev/pts/1"/>
      <target port="0"/>
   <interface type='bridge'>
      <mac address='fa:16:3e:81:00:01'/>
      <source bridge='virbr0'/>
      <model type='virtio'/>
      <driver name='qemu'/>
      <alias name='net0'/>
    <channel type='unix'>
      <source mode='bind'/>
      <target type='virtio' name='org.qemu.guest_agent.0'/>
    <input type="tablet" bus="usb"/>
    <input type="mouse" bus="ps2"/>
    <graphics type="vnc" port="-1" autoport="yes" keymap="en-us" listen=""/>
    <qemu:arg value='-machine'/>
    <qemu:arg value='smm=off'/>


reply via email to

[Prev in Thread] Current Thread [Next in Thread]