[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] Defining a bridge

From: Jerry Stuckle
Subject: Re: [Qemu-discuss] Defining a bridge
Date: Mon, 24 Oct 2016 21:10:11 -0400
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Thunderbird/45.4.0

Anyone have an idea on this?

On 10/21/2016 3:37 PM, Jerry Stuckle wrote:
> Alexsei and all,
> Well, I screwed up and responded to Aleksei directly instead of to the
> list.  I really do appreciate his help; he's a lot more knowledgeable
> than I am in this area.  In an attempt to catch up on this, here's
> what's happened.
> I tried loading virtio_net module; it also loaded the virtio and
> virtio_ring modules, but no luck.  Still no device in Debian.  Aleksei
> also recommended trying to load the virtio_mmio, but it does not exist
> on my system.
> My /etc/network/interfaces file contains the default:
> # This file describes the network interfaces available on your system
> # and how to activate them. For more information, see interfaces(5).
> # The loopback network interface
> auto lo
> iface lo inet loopback
> # The primary network interface
> allow-hotplug eth0
> iface eth0 inet dhcp
> Again, this setup is: Windows 7 as the base OS with two nics, wired and
> wireless (only one active at a time).  Under this I have Oracle Virtual
> Machine running Ubuntu 4.4.0-38-generic (latest stable release).  I have
> set up a bridge in Ubuntu's Network Manager as described on
> http://ask.xmodulo.com/configure-linux-bridge-network-manager-ubuntu.html.
>  The bridge is defined as "bridge0" and works correctly in Ubuntu.
> I start QEMU under Ubuntu with:
> qemu-system-arm -m 1024M \
>       -sd /export/armhf.qcow2 \
>       -M vexpress-a9 \
>       -cpu cortex-a9 \
>       -kernel /export/boot/vmlinuz \
>       -initrd /export/boot/initrd.img \
>       -append "root=/dev/mmcblk0p2" \
>       -device virtio-net-device,netdev=net0 \
>       -netdev 
> bridge,br=bridge0,id=net0,helper=/usr/lib/qemu/qemu-bridge-helper
> Guest system is Debian 3.2.0-4-vexpress, again the latest stable
> version.  I get a SLIRP connection just fine when I don't specify the
> -device and -netdev parameters.  The "lshw" shows the driver to be
> smsc911x, but I don't know how to relate that to which NIC is being
> emulated (it at least works).
> When I do specify the -device and -netdev parameters, I get no network.
> The log shows nothing unusual other than no network device is found.
> I'm also going to ask in the qemu-arm forum, just in case there's a
> known problem there.  But I would appreciate any other help and ideas
> from Aleksei and others.  Hopefully this catch-up will jog someone's memory.
> Thanks again for everyone's help, especially Aleksei.
> Jerry

reply via email to

[Prev in Thread] Current Thread [Next in Thread]