[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] problem with virtio disk driver

From: Aleksei
Subject: Re: [Qemu-discuss] problem with virtio disk driver
Date: Fri, 21 Oct 2016 16:59:46 +0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.4.0

> Thinking it might be because I had an old version of qemu I upgraded qemu to v 2.6.0. And got the same behavior.

libvirt 1.2.20 is also pretty old, current one is 2.3.0, maybe you can try that. This Embedded Linux you're running as host - which arch is it (ARM, x86_64 etc)?

--Regards, Aleksei

From: Andrei Perietanu
Sent: Friday, October 21, 2016 4:47PM
To: Qemu-discuss
Subject: Re: [Qemu-discuss] problem with virtio disk driver
Just in case this sparks anyone's interest, the problem is still not solved, not even upgrading the host's kernel form 3.18 to 4.7.8
There is something I'm missing here..

On Thu, Oct 13, 2016 at 3:51 PM, Andrei Perietanu <address@hidden> wrote:
I just ran into a problem I can't make heads or tails of, so I'm hoping to get some help here.

I have a custom built Embedded Linux as host, running qemu-kvm  1.1.2 and libvirt 1.2.20

I'm creating a domain with the following config:

<domain type='kvm'>
  <memory unit='KiB'>2097152</memory>  
  <vcpu placement='static'>2</vcpu>  
    <type arch='x86_64'>hvm</type>
    <boot dev='hd'/>  
    <boot dev='cdrom'/>    
  <cpu mode='host-model'/>
  <clock offset='utc'>
    <timer name='rtc' tickpolicy='catchup'/>
    <timer name='pit' tickpolicy='delay'/>
    <timer name='hpet' present='no'/>
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <target dev='hdb' bus='ide'/>
      <source file='custom.iso'/>
    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2'/>
      <source file='/path/to/vdisk.img'/>
      <target dev='vda' bus='virtio'/>      
    <controller type='pci' model='pci-root'/>
    <controller type='usb'/>
    <controller type='ide'/>
   <interface type='bridge'>
      <source bridge='virbr0'/>      
      <model type='virtio'/>
    <serial type='pty'>
      <target port='0'/>
    <console type='pty'>
      <target type='serial' port='0'/>
    <input type='tablet' bus='usb'/>
    <input type='mouse' bus='ps2'/>
    <input type='keyboard' bus='ps2'/>
    <graphics type='vnc' port='-1' autoport='yes'/>
      <model type='qxl' ram='65536' vram='65536' vgamem='16384' heads='1'/>
    <watchdog model='i6300esb' action=''/>
    <memballoon model='none'/>   

Granted the guest OS I'm installing is again a custom Linux with some software running on top ..so It's not a well known OS...but I'm hoping that does not matter much. 
After installation I get all sorts of kernel panics and errors about services not being able to start. 

I tried the same thing on ubuntu 14.04.2 LTS (host) which installed qemu-kvm 2.0.0 and libvirt 1.2.2

Same config xml, but this time it worked better -I was not getting the kernel panics.
The OS I'm installing does not support IDE disks, it needs a virtio disk.

I ran a second test, this time installing ubuntu 14.04 as the guest on both hosts (ubuntu vs embedded Linux) and again I had problems with which point to the virtio driver.

On the ubunutu host everyhing was fine 
On the Embedded Linux host, the installation failed early on with the error:
   The attempt to mount a file system with type ext4 in Virtual disk1, partition#1 (vda1) at / failed
If I switch to an ide disk drive instead of virtio, everything works fine.

Thinking it might be because I had an old version of qemu I upgraded qemu to v 2.6.0. And got the same behavior.

At this point I'm running out of ideas and I'm not sure what else I can try. Any suggestions are appreciated.


The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited. If you receive this in error please contact the sender and delete the material from any computer immediately. It is the policy of Klas  Limited to disavow the sending of offensive material and should you consider that the material contained in the message is offensive you should contact the sender immediately and also your I.T. Manager.

Klas Telecom Inc., a Virginia Corporation with offices at 1101 30th St. NW, Washington, DC 20007.

Klas Limited (Company Number 163303) trading as Klas Telecom, an Irish Limited Liability Company, with its registered office at Fourth Floor, One Kilmainham Square, Inchicore Road, Kilmainham, Dublin 8, Ireland.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]