[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] Cannot connect to network

From: Jerry Stuckle
Subject: Re: [Qemu-discuss] Cannot connect to network
Date: Fri, 7 Oct 2016 16:28:24 -0400
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Thunderbird/45.4.0

Hi, Aleksei, and thanks for the response.

Yes, I read that I should get a default SLIRP network, which is why I'm
surprised it doesn't work.  I have tried a lot of other things, but went
back to this as the simplest case just to get *something* working :<.

I've fooled around with this a bit more, changing parameters on both the
host and the guest.  I don't know what I did, but I can now get to the
internet, so that's a start.  I'm updating the Debian system now.  Slow,
but that's OK - it's working and I can do other things while it's updating.

Now I have to try to understand bridging.  It's one of the things I
tried before writing, and all I managed to do was disable the network
for Ubuntu, also :).  But I'll try again.

Thanks for the help.  I figured as soon as I gave up and asked someone
would point out the stupid thing I was doing (most likely) or it would
start working!


On 10/7/2016 3:33 PM, Aleksei wrote:
> Hi Jerry,
> You didn't specify network options in qemu command, so it created a
> default SLIRP network for your Debian guest. If you can access internet
> from Ubuntu, it's weird that you can't access it from Debian - I don't
> know why. Can your Ubuntu VM access internet regardless of which host
> interface is up (wireless/Ethernet)?
> See here for available Qemu networking options:
> http://wiki.qemu.org/Documentation/Networking#User_Networking_.28SLIRP.29
> If you want Debian VM to be on the same network as your host, like
> Ubuntu does, you can set up a bridge in Ubuntu, specify Ubuntu's NIC as
> a slave and have Qemu tap into it as well. It will be a tricky "layered
> bridging" setup, but I think it'll work. See here for info on creating
> bridges in Ubuntu https://help.ubuntu.com/community/NetworkConnectionBridge
> Hope this gives you enough pointers to at least get started.
> /--Regards, Aleksei/
> ------------------------------------------------------------------------
> *From:* Jerry Stuckle
> *Sent:* Friday, October 07, 2016 7:49PM
> *To:* Qemu-discuss
> *Subject:* [Qemu-discuss] Cannot connect to network
>> Hi, all,
>> First of all, I will admit I'm a programmer, not a Linux administrator,
>> so the problem can be anywhere.  But I strongly suspect it's in the way
>> I'm setting up QEMU.
>> Here's the setup.  Main system is Window 7.  Underneath that, I am
>> running Ubuntu in VirtualBox.  This is working OK; I have two
>> NICs on the machine (wired and wireless, only one active at any one
>> time); VirtualBox is set up to bridge two virtual NICs to the two real
>> NICs, and the appropriate one is active in Ubuntu and gets an IP address
>> from the DHCP server.
>> Running QEMU 2.5.0 (the latest available in Ubuntu) I'm trying to bring
>> up a Debian system with:
>> qemu-system-arm -m 1024M \
>>              -sd /export/armhf.qcow2 \
>>              -M vexpress-a9 \
>>              -cpu cortex-a9 \
>>              -kernel /export/boot/vmlinuz \
>>              -initrd /export/boot/initrd.img \
>>              -append "root=/dev/mmcblk0p2"
>> This works fine, except the ethernet port (eth0) gets an ip address of
>> instead of one from our intranet and can't access anything on
>> the intranet or the internet.  (The interface is defined in Debian for
>> DHCP on eth0).
>> Right now I need to be able to connect and update the Debian system.
>> Eventually I will need other outbound services also, to connect to both
>> intranet and internet systems.
>> I will also eventually need to be able to connect into this system
>> (multiple ports/processes).  I know I can use hostfwd, but I'd much
>> rather have the guest system allocated an ip from our intranet.
>> Does anyone have a suggestion as to what I'm doing wrong, and how I can
>> correct it?  Hours of searching on the internet have turned up very little.
>> TIA,
>> Jerry

reply via email to

[Prev in Thread] Current Thread [Next in Thread]