[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] QEMU with kvm give "Guest has not initialized the dis

From: Nutaro, James J.
Subject: Re: [Qemu-discuss] QEMU with kvm give "Guest has not initialized the display"
Date: Wed, 10 Aug 2016 16:14:48 +0000

Thanks for the quick response. I looked into this a bit more, and found that if 
I build qemu-2.3 from source, the -enable-kvm option works; everything runs 
fine. Any later version, it fails. I also noticed that qemu-2.3 is what is 
available via the Ubuntu 15.10 distribution that I am using. Compiling source 
from the git repository, I found that qemu never returns from an ioctl call 
that hands control over to kvm. Specifically, it stalls on th call


in the function kvm_cpu_exec.

It doesn't stall on the first call to this function, but rather after a score 
or so.

Is there possibly a KVM versioning mismatch? Any ideas?


-----Original Message-----
From: Peter Maydell [mailto:address@hidden 
Sent: Sunday, August 07, 2016 3:33 PM
To: Nutaro, James J.
Cc: address@hidden
Subject: Re: [Qemu-discuss] QEMU with kvm give "Guest has not initialized the 

On 5 August 2016 at 19:50, Nutaro, James J. <address@hidden> wrote:
> I've found a handful of posts mentioning this problem,
> but no solutions yet. The command line that I'm trying to run with is
> qemu-system-i386 --enable-kvm disk.img
> If I remove the --enable-kvm it runs fine. Otherwise,
> I get a blank screen with the message  "Guest has not
> initialized the display".

This message just means "the guest hasn't tried to
talk to the VGA card yet". It can happen for a wide
range of problems which are variants of "the guest
crashed very early on before it tried to print anything".

So the thing which causes this message for one person
is not necessarily the thing which causes it for
somebody else, and the solutions are different then too.

-- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]