[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] Problem converting from vmdk to raw format

From: Jakob Bohm
Subject: Re: [Qemu-discuss] Problem converting from vmdk to raw format
Date: Mon, 1 Feb 2016 07:55:33 +0100
User-agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Thunderbird/38.5.1

qemu-img used the "sparse file" feature of your file system to not
actually allocate disk sectors for many of the all-zero blocks in
the raw file.  Your iso creation tool did not.

On 01/02/2016 05:42, Alexandre Schenberg wrote:
thanks, was a permission problem, to change it solved the issue
  I have another doubt, converting it to raw generate a 126.9GB file.
  However df shows that the space used in the partition is only 8.x GB.
  And now I am converting the raw file to an iso file and the iso is
  really occupying space.
  So why the space occupied by the raw file seems to do not exists and
  the one from Iso does?
  And why the Iso is becaming so big?

  Thanks for the aid.

2016-02-01 2:40 GMT-02:00, Fam Zheng<address@hidden>:
On Mon, 02/01 01:53, Alexandre Schenberg wrote:
Hello, I tried to convert a .vmdk file to a raw file with this
command: "qemu-img convert -f vmdk /media/windows/WinXP-disk1.vmdk

The result was: "qemu-img: Could not open

I am sure that the vmdk file, WinXP-disk1.vmdk it is in the dir

So what I am doing wrongly?
Which qemu-img version are you using? Or which commit in the case of git


Jakob Bohm, CIO, Partner, WiseMo A/S.  http://www.wisemo.com
Transformervej 29, 2860 Soborg, Denmark.  Direct +45 31 13 16 10
This public discussion message is non-binding and may contain errors.
WiseMo - Remote Service Management for PCs, Phones and Embedded

reply via email to

[Prev in Thread] Current Thread [Next in Thread]