[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] Nested Qemu/KVM Performance Degradation

From: Jan Teske
Subject: [Qemu-discuss] Nested Qemu/KVM Performance Degradation
Date: Thu, 7 Jan 2016 17:21:19 +0100
User-agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:38.0) Gecko/20100101 Thunderbird/38.5.0


I am trying to run a Windows guest in a nested VM configuration using Qemu/KVM.

The setup is as follows:

- host:
    - CPU: Intel(R) Xeon(R) CPU E5-2420 v2 @ 2.20GHz (6 cores)
    - RAM: 16 GB
    - OS: Ubuntu Server 14.04, 64bit
- outer VM (running in normal virtualization on the host):
    - Qemu/KVM running Ubuntu Server 14.04, 64bit
    - cmdline:
        $ qemu-system-x86_64 \
                -m 8192 \
                -cpu host \
                -drive file=/dev/mapper/vmray-nested,cache=none,if=virtio \
                -vnc :0 \
    - the virtual disk is an LVM volume, 200 GB in size
- inner VM (running in nested virtualization inside the outer VM):
    - Qemu/KVM running Windows 7 Pro, 64bit
    - cmdline:
        $ qemu-system-x86_64 \
                -m 2048 \
                -cpu host \
                -drive file=win7.img,cache=none \
                -vnc :0 \
- for the virtual disk I tried both a qcow2 and a raw image, 50 GB in size

Both VMs run without producing any visible errors. However, I experience an extreme performance degradation in the inner VM. Installing Windows inside the inner VM takes roughly 30 times longer than performing the installation under normal (i.e., non-nested) virtualization.

This seems to be a problem of Qemu/KVM, not of the underlying hardware. I tested the same setup using VMWare Player instead of Qemu/KVM. In this configuration, the inner VM is not significantly slower than the outer VM. Finally, I also tried running VMWare Player as the outer hypervisor and Qemu/KVM as the inner hypervisor, which also provided me with acceptable speed. Hence, it seems to me that the problem lies either in Qemu/KVM's support for nested virtualization or in the hypervisor configuration I chose.

Can anyone help me spot the problem? And has anyone successfully run Qemu/KVM in a nested configuration before?

Best regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]