[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] Issues with QEMU on Tegra K1 _HOST_.

From: jscottkasten
Subject: [Qemu-discuss] Issues with QEMU on Tegra K1 _HOST_.
Date: Tue, 1 Sep 2015 13:39:04 +0000 (UTC)

Hi guys,  I'm hoping maybe some of you have some information on a problem that 
I am seeing.

I have tried using QEMU on an ARM host, specifically a Tegra K1, and have found 
it almost completely unusable. Usually the guest OS hangs and never frees up.  
Sometimes the guest starts reporting errors or crashes in quest applications 
that doesn't happen using the same guest on a non-ARM host.

I've looked through the mailing list and found one reference last year that 
seems to be the same problem:


I have tried many things to narrow this down, but nothing has helped.  I've 
tried building QEMU versions 2.1.2, 2.2.1, 2.3.1, and 2.4.0.  I've tried 
compiling QEMU on the Debian ARMHF arch (hard float), and the plain (soft 
float) ARM arch.  I've tried versions of GCC from 4.1, 4.5, 4.8, and 4.9.  I've 
tried guests from Debian, NetBSD, OpenBSD, MIPS64, x86_64, and SPARC64.

NONE of this has worked to produce even a single usable VM image.  I've tried 
"formulas" found in various places on the web for versions of QEMU, guest OS, 
arch, and emulated device selection.  All to no avail.  Yet I can take one of 
these formulas to an x86 host and it will work strait away.

The gist is that _something_ is horribly broken when qemu is used on an ARM 
host.  I'm open to any suggestions that anyone might have.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]