[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] How to enable virtio-blk data plane ?

From: Chengyuan Li
Subject: Re: [Qemu-discuss] How to enable virtio-blk data plane ?
Date: Tue, 21 Apr 2015 22:54:23 +0800


This problem is solved now.
I need put XML namespace as below.

<domain type='kvm' xmlns:qemu='http://libvirt.org/schemas/domain/qemu/1.0'>


From: address@hidden
To: address@hidden
Date: Mon, 20 Apr 2015 14:46:01 +0800
Subject: [Qemu-discuss] How to enable virtio-blk data plane ?


I tried to enable virtio-blk data plane feature for VMs in my openstack environment,  the hypervisor is ubuntu 14.04, libvirt 1.2.2 and QEMU 2.0.
. As nova doesn't support that parameter yet, I did belows

1. nova boot a VM with raw disk image.
2. nova stop the VM.
3. run "virsh edit <instance-id>" on the hyprvisor node, and adding below into instance xml just before </domain>

    <qemu:arg value='-set'/>
    <qemu:arg value='device.drive-virtio-disk0.x-data-plane=on'/>

4. nova start the VM.

But seems that it doesn't work, could anyone help and let me know how to enable virtio-blk data plane? 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]