[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] Question regarding configuring PVSCSI with QEMU / KVM

From: Singhal, Upanshu
Subject: Re: [Qemu-discuss] Question regarding configuring PVSCSI with QEMU / KVM
Date: Thu, 11 Dec 2014 11:54:28 +0000

Hello Mike,


Thanks a lot for your email. This time my installation went through, instead of using .qcow2, I used file as .img type. But, after installation, vm does not boots up and went into installation mode again. This behavior seems to be similar as what you have mentioned below that vm boot looks for ide drive to boot up and does not boot with pvscsi.


I am also not able to connect the vm using qemu-connect, I always get errors like: error: unsupported configuration: No monitor connection for pid 3474 or error: internal error: missing index/unit/bus parameter in drive 'file=/var/lib/libvirt/images/fedora-1.img


Can you please tell me what Linux you are running on your KVM host and what KVM and QEMU version you are using?


Please reply.


Thanks a lot for your help.





From: address@hidden [mailto:address@hidden
Sent: Thursday, December 11, 2014 8:21 AM
To: Singhal, Upanshu; address@hidden
Subject: Re: [Qemu-discuss] Question regarding configuring PVSCSI with QEMU / KVM


On Wed, Dec 10, 2014, at 06:10 AM, Singhal, Upanshu wrote:

Hello Mike,


Thanks for your email and help, I really appreciate it. I tried with the method mentioned by you couple of times, but my vm installation gets hang always in the middle. I tried the following command:


qemu-system-x86_64 -enable-kvm -smp 2 -m 2048 -device pvscsi,id=scsi0 -drive file=/var/lib/libvirt/images/fedora20-2.qcow2,id=hd0,if=none -device scsi-disk,drive=hd0,bus=scsi0.0 -cdrom /root/Downloads/Fedora-20-x86_64-DVD.iso


I have couple of question, is qemu-system-x86_64 equivalent to qemu-kvm? Will I be able to manage the VMs created by this command using libvirt?



i just went trough the Fedora 20 installation using a pvscsi disk controller. the installation completed as expected. i did have a problem in that the vm would not boot from from disk attached to pvscsi. my guess is that the version of seabios i have installed does not support booting from a pvscsi controller. i attempted to get a newer version of seabios that supposedly has the support but was unable to get it to work.


these days, qemu-kvm should be the same as qemu-system-x86_64. when the kvm kernel module was first released, the userspace support was in a forked version of qemu call qemu-kvm. since then, the two have merged back together. qemu-system-x86_64 is the qemu binary to run a 64 bit x86 full virtual machine.


in theory, you should be able to get libvirt to start managing qemu vms that were started manually by using the qemu-attach command in virsh. i don't think it will work in this case though because libvirt does not recognize pvscsi as a valid model for a scsi controller for qemu. libvirt does recognize that model of scsi controller for an esx vm. my guess is that support would need to be added to libvirt to be able to use pvscsi controllers with qemu. this might not matter if you still can't have vm boot from pvscsi in qemu.


sorry to just give bad news.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]