[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] OS/2 v2.11 networking issue

From: Saddic, Rick (ES)
Subject: [Qemu-discuss] OS/2 v2.11 networking issue
Date: Wed, 26 Nov 2014 17:39:18 +0000


We need to virtualize the subject operating system.  We have been unsuccessful using Virtualbox.  However, a note on the Virtualbox discussion board said that they heard that Qemu had some success with virtualizing OS/2.  If so, can you help me.  The following is an excerpt of the problem we are currently facing with VirtualBox.  I am hopeful that someone can report that they have overcome the networking issue with Qemu.  Please respond if you have done so. Thank you.




On the unclassified Windows XP computer, I simplified the setup. I ran the OS/2 VM as an internal-network only, no bridge nor NAT. I set the XP host IP address to, and set the OS/2 VM address to I then ran Wireshark on XP computer to sniff everything on the internal network (i.e., all 192.168.0.x traffic). When I initiated a ping from OS/2 to XP, I can see the ARP broadcast "Who is Tell", as well as confirming the MAC within the ARP matched what I gave to OS/2. XP then replied with the correct ARP resolution.

Within OS/2, I watched the network statistics (netstat -i). I could see that the transmit count increased. However, the receive count never changed from zero.

There are [at least] four possible reasons for the observed behaviors:

1. XP has a firewall blocking outbound ARP.
2. VirtualBox does not route outbound Ethernet frames to the OS/2 VM virtual device.
3. The installed virtual device does not signal to OS/2 of a received Ethernet frame.
4. OS/2 has a firewall to ignore messages from the virtual device.

As for #1, I explicitly disabled all Windows firewall.
As for #2, I have not seen VirtualBox fail to route messages to other operating systems.
As for #4, I do not believe this version of OS/2 has a notion of firewalls.

That leaves me to believe the reason is #3. This version of OS/2 is old enough to not have native support for any of the possible VirtualBox network adapters. We tried a few different virtual adapters and OS/2 drivers, none of which worked. VirtualBox supports two families of network adapters - AMD PCNet and Intel e1000. I tried updating the PCNet driver with ones I found online, none of which worked. I tried installing an e1000 driver, but that did not work either. (A blog posted claimed that this particular version of OS/2 cannot use that particular e1000 driver.)





reply via email to

[Prev in Thread] Current Thread [Next in Thread]