[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] [Solved] Installed Ubuntu 14.04 and now getting "unkn

From: Hans Deragon
Subject: Re: [Qemu-discuss] [Solved] Installed Ubuntu 14.04 and now getting "unknown OS type hvm" on my old VMs.
Date: Tue, 07 Oct 2014 03:44:41 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.1.2


I solved the problem.  The solution is embarrassing;  Qemu and KVM were
not installed.  I assumed (wrongly) that by installing the 'libvirt-bin'
package, the other packages would install as dependencies but I was
wrong.  What mislead me is that many directories with 'qemu' in their
names are created when installing 'libvirt-bin', such as
'/etc/libvirt/qemu', giving the false impression that everything is
there.  It is by using the GUI (virt-manager) instead of the CLI (virsh)
that I got an error stating that Qemu was not installed.

If any libvirt developer is reading this, a better error message would
be appreciated.  Something like "No virtual manager installed.  Please
install one such as Qemu." would be appreciated.

I send my Thanks to Jakob Bohm and Ziemowit Pierzycki for answering my
original email.

Best regards,
Hans Deragon

On 14-10-05 10:13 PM, Hans Deragon wrote:> Greetings,
> I installed Ubuntu 14.04 64 bits and am now getting "unknown OS type
> hvm" when I try 'virsh define <servername>' on my old VMs.
> A search trough the web suggest that kernel modules are not loaded.  I
> my case, they are:
> # lsmod | fgrep kvm
> kvm_intel             143109  0
> kvm                   451511  1 kvm_intel
> Other suggest that the BIOS is not configured for Virtualization. My old
> Ubuntu 12.04 64 bits is still available via dualboot, and the same VMs
> start fine under it.  It is not the BIOS.
> My system supports 'vmx' (it is a DX58SO Intel motherboard support VT-d.
> # egrep "^flags" /proc/cpuinfo  | fgrep --color vmx^
> flags        : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
> cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall
> nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology
> nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16
> xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm ida dtherm tpr_shadow vnmi
> flexpriority ept vpid
> I spent an hour looking through the web to no avail.  Anybody can tell
> me what the problem is and why my VMs work under 12.04 but not on 14.04,
> on the same hardware and same BIOS settings?  I am out of options here;
> it should work.
> My system is fully updated with the latest packages.  Could there be a
> dependency missing (forgotten in a .deb)?
> # uname -a
> Linux <servername> 3.13.0-36-generic #63-Ubuntu SMP Wed Sep 3 21:30:07
> UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
> Best regards,
> Hans Deragon

reply via email to

[Prev in Thread] Current Thread [Next in Thread]