[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] qemu-system-arm hangs on OSX

From: Brad Smith
Subject: Re: [Qemu-discuss] qemu-system-arm hangs on OSX
Date: Tue, 30 Sep 2014 12:03:14 -0400

Well, that complicates our testing plans somewhat, but thanks very much for the quick and helpful answer!


On Tue, Sep 30, 2014 at 11:32 AM, Peter Maydell <address@hidden> wrote:
On 30 September 2014 16:18, Brad Smith <address@hidden> wrote:
> Anyway, I can now boot the Debian installer. But I'm still having problems
> when I try to boot the Cubuietruck version of lubuntu. Specifically, it
> fails with a "qemu: fatal: Trying to execute code outside RAM or ROM at ..."
> error.

This error message just means "the guest tried to execute from a bad
address which isn't RAM on this board". If it happens immediately
on startup it almost always means "you tried to boot a kernel for board
X on QEMU's board model Y". We don't model the cubietruck, and
attempting to boot a cubietruck-only kernel on one of the boards QEMU
does support is just going to fail like this. (The other common failure mode
is "no output at all", which is what happens when the guest kernel
crashes before it writes anything to the serial port).

-- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]