[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] quick start help after build

From: Mike Lovell
Subject: Re: [Qemu-discuss] quick start help after build
Date: Wed, 30 Jul 2014 12:55:25 -0600
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0

On 07/30/2014 12:21 PM, graff zeltner wrote:

I've built version 2.0.95 with the following sequence of steps:
'git clone git://git.qemu-project.org/qemu.git'
'./configure' halted on missing libfdt, so used
'git submodule update --init dtc' to fix missing dependency
'./configure --prefix=/home/graf/test/qemu --target-list="i386-linux-user 
'make all' && 'make install'

you probably wanted --target-list to be "i386-softmmu x86_64-softmmu" and not the linux-user ones. the softmmu targets are the ones that build the qemu-system-i386 and qemu-system-x86_64 programs. those will match what you were doing before. qemu-i386 and qemu-x86_64 are for an very different use case and have a different method of invoking them.

Now in ~/test/qemu directory I have bin/ etc/ libexec/ share/ and var/ 
directories with bin/ showing
At this point I would have installed in the /usr/local where all these files 
belong, except I could not
run the program. Tried quick start document section to no avail.
The old command sequence did not work.
'qemu-system_x86_64 -L . -m 1024 -boot c -hda harddisk.img' -> no such file 'qemu-system-x86_64' 'qemu-x86_64 -L . -m 1024 -boot c -hda harddisk.img' -> usage 'qemu-86_64 [options] program [arguments]'

The options section (usage help) does not show any "useful" help for setting even the basic parameters. Was that the intended design decision? Instead we are faced with environment options variables which, I am sorry if you did not realize yet, they for the most part are gibberish. Viz. there is not a section in the documentation that covers them, and the documentation still has 'qemu-system-x86_64' where the 'system' keyword has been dropped. You have to weed through the entire documentation and examine every option, and even then you are not yet ready to set the environment options.

I've tried both qemu-i386 and qemu-x86_64 adding file-descriptor options
'qemu-i386 -add-fd fd=3,set=2,opaque="rdwr:/home/graff/harddisk.img"

or even boot order
qemu-system-i386 -boot order=nc harddisk.img

The 'usage options' for example do not echo 'invalid or unrecognized option'. 
Every attempt brings you back to the same
useless options menu

At this point, it appears to me the program failed, but what is worse the developers failed. You have just bought yourself a brand spanking new car, the dealer handed you the keys, and you cannot open the car door or find where the ignition key gets inserted.

it may appear the program has failed but it hasn't and neither have the developers. every thing you have been describing sounds like it has been behaving as the developers intended but only appears to be broken due to a mis-understanding.

for your original problem of the virtual machines being slow, i would recommend adding the --enable-kvm to you qemu-system-x86_64 or qemu-system-i386 commands. i am assuming that you are using a linux system to run qemu on. using --enable-kvm will enable qemu to use the kvm kernel module to accelerate the performance of the vm. you may need to make sure that the kvm kernel module and either the kvm_intel or kvm_amd kernel module are loaded. the user executing qemu-system-x86_64 or -i386 will need permission to read and write to /dev/kvm.

i hope that all helps.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]