[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] quick start help after build

From: graff zeltner
Subject: Re: [Qemu-discuss] quick start help after build
Date: Wed, 30 Jul 2014 20:21:03 +0200


I've built version 2.0.95 with the following sequence of steps:
'git clone git://git.qemu-project.org/qemu.git'
'./configure' halted on missing libfdt, so used
'git submodule update --init dtc' to fix missing dependency
'./configure --prefix=/home/graf/test/qemu --target-list="i386-linux-user x86_64-linux-user"'
'make all' && 'make install'

Now in ~/test/qemu directory I have bin/ etc/ libexec/ share/ and var/ directories with bin/ showing
At this point I would have installed in the /usr/local where all these files belong, except I could not
run the program. Tried quick start document section to no avail.
The old command sequence did not work.
'qemu-system_x86_64 -L . -m 1024 -boot c -hda harddisk.img' -> no such file 'qemu-system-x86_64'
'qemu-x86_64 -L . -m 1024 -boot c -hda harddisk.img' -> usage 'qemu-86_64 [options] program [arguments]'

The options section (usage help) does not show any "useful" help for setting even the basic parameters. Was that the intended
design decision? Instead we are faced with environment options variables which, I am sorry if you did not realize yet, they for the most part are gibberish. Viz. there is not a section in the documentation that covers them, and the documentation still has 'qemu-system-x86_64' where the 'system' keyword has been dropped. You have to weed through the entire documentation and examine every option, and even then you are not yet ready to set the environment options.

I've tried both qemu-i386 and qemu-x86_64 adding file-descriptor options
'qemu-i386 -add-fd fd=3,set=2,opaque="rdwr:/home/graff/harddisk.img"

or even boot order
qemu-system-i386 -boot order=nc harddisk.img

The 'usage options' for example do not echo 'invalid or unrecognized option'. Every attempt brings you back to the same
useless options menu
usage: qemu-i386 [options] program [arguments...]
Linux CPU emulator (compiled for i386 emulation)
Options and associated environment variables:
Argument      Env-variable      Description
-h                              print this help
-g port       QEMU_GDB          wait gdb connection to 'port'
-L path       QEMU_LD_PREFIX    set the elf interpreter prefix to 'path'
-s size       QEMU_STACK_SIZE   set the stack size to 'size' bytes
-cpu model    QEMU_CPU          select CPU (-cpu help for list)
-E var=value  QEMU_SET_ENV      sets targets environment variable (see below)
-U var        QEMU_UNSET_ENV    unsets targets environment variable (see below)
-0 argv0      QEMU_ARGV0        forces target process argv[0] to be 'argv0'
-r uname      QEMU_UNAME        set qemu uname release string to 'uname'
-B address    QEMU_GUEST_BASE   set guest_base address to 'address'
-R size       QEMU_RESERVED_VA  reserve 'size' bytes for guest virtual address space
-d item[,...] QEMU_LOG          enable logging of specified items (use '-d help' for a list of items)
-D logfile    QEMU_LOG_FILENAME write logs to 'logfile' (default stderr)
-p pagesize   QEMU_PAGESIZE     set the host page size to 'pagesize'
-singlestep   QEMU_SINGLESTEP   run in singlestep mode
-strace       QEMU_STRACE       log system calls
-version      QEMU_VERSION      display version information and exit
QEMU_LD_PREFIX  = /usr/gnemul/qemu-i386
QEMU_STACK_SIZE = 8388608 byte
You can use -E and -U options or the QEMU_SET_ENV and
QEMU_UNSET_ENV environment variables to set and unset
environment variables for the target process.
It is possible to provide several variables by separating them
by commas in getsubopt(3) style. Additionally it is possible to
provide the -E and -U options multiple times.
The following lines are equivalent:
    -E var1=val2 -E var2=val2 -U LD_PRELOAD -U LD_DEBUG
    -E var1=val2,var2=val2 -U LD_PRELOAD,LD_DEBUG
Note that if you provide several changes to a single variable
the last change will stay in effect.

At this point, it appears to me the program failed, but what is worse the developers failed. You have just bought yourself a brand spanking new car, the dealer handed you the keys, and you cannot open the car door or find where the ignition key gets inserted.

With kind regards,

Sent: Wednesday, July 30, 2014 at 11:59 AM
From: "Dale R. Worley" <address@hidden>
To: "graff zeltner" <address@hidden>
Cc: address@hidden
Subject: Re: [Qemu-discuss] quick start help after build
> From: "graff zeltner" <address@hidden>
> Date: Wed, 30 Jul 2014 08:56:59 +0200
> I was pleasantly surprised to find a plethora of options in the
> latest qemu version 2.0.95. I have spent a couple of hours reading
> the documentation, and unfortunately was not able to run the program
> to see if everything works. I have a file generated by version
> 1.7.50 which I was running with qemu-system-x86_64. None of the
> previous options seem to work. I have a harddisk.img file which runs
> on 32-bit and 64-bit machine, except that on 64-bit it takes 30+
> minutes to boot tinycore linux with qemu. On a 32-bit one, this
> process takes about 10 minutes. I wanted to try the latest version
> to see if it can be accelrated a bit. I&#39;ve tried several
> different options, but I am stuck at the help menu. Could not boot
> anything with &#39;qemu-x86_64 -L /path/to/harddisk.img&#39; or any
> other options.<br/>

> Any suggestion will be greatly appreciated.<br/>

It would greatly help us if you showed exactly what command line(s)
you have tried, exactly what messages you received, exactly what
failures you observed, etc. Otherwise, we are reduced to random



reply via email to

[Prev in Thread] Current Thread [Next in Thread]