[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] Qemu and vde not working

From: Ming-Ching Tiew
Subject: [Qemu-discuss] Qemu and vde not working
Date: Wed, 16 Jul 2014 14:48:25 -0700

I am using ubuntu 14.04 64 bit LTS with qemu 2.0.0-dfsg-2ubuntu1

My qemu scripts using vde is like this :-

  #  vde_switch -sock /tmp/vde.ctl0 -tap tap0 -daemon --mgmt /tmp/myvde.mgmt0
   # vde_switch -sock /tmp/vde.ctl1 -tap tap1 -daemon --mgmt /tmp/myvde.mgmt1
 # cat qemu.hd.vde2
qemu-system-i386 -enable-kvm \
 -net nic,model=rtl8139,vlan=0,macaddr=00:90:00:00:00:22 \
 -net nic,model=rtl8139,vlan=1,macaddr=00:45:12:00:00:21 \
 -boot c -m 512 -hda /tmp/hd.test \
 -net vde,vlan=0,sock=/tmp/vde.ctl0 \
 -net vde,vlan=1,sock=/tmp/vde.ctl1

All these scripts used to be working when I am running a older system. Then I recently change the distro to ubuntu 14.04 (64bit) with qemu 2.0.0, then when I run the script qemu.hd.vde2, it complains these :-

Warning: vlan 0 is not connected to host network
Warning: vlan 1 is not connected to host network

I lost the connectivity in the guest OS ! I tried using qemu-system-x86_64, still networking is not working.

( I also have virtualbox installed on this machine with networking using vde. The vde networking is working with virtualbox ).

Any clues ?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]