[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] Trouble starting various qemu-system-*.exe on Windows 7

From: Steere, Andy
Subject: [Qemu-discuss] Trouble starting various qemu-system-*.exe on Windows 7
Date: Tue, 10 Jun 2014 23:50:59 +0000

Newbie problem: I'm having trouble getting qemu to run a mipsel Debian VM. I’m using qemu version 2.0.50 x86 which I downloaded from http://qemu.weilnetz.de/w32/qemu-w32-setup-20140529.exe. I also tried the qemu-w32-setup-20130619.exe from the same website with the same results.


When I run qemu-system-mipsel.exe there is no output or Windows event log entries. Here is the command line:

                qemu-system-mipsel -M malta -kernel vmlinux-3.2.0-4-4kc-malta -hda debian_wheezy_mipsel_standard.qcow2 -append "root=/dev/sda1 console=tty0"


When I start qemu-system-mipsel.exe without arguments there is no output or Windows event log entries.


My testing was on the following Windows OS:

1. Windows 7 Pro SP1 x64 with Mingw installed

2. Win7 Pro SP1 x32 VM without Mingw installed.


I am able to get qemu to run a mipsel Debian in an Ubuntu 14.0 VM which would validate the vm and qcow files.


The Windows qemu installation appears to be good because I can get an i386 Ubuntu version running on the Win7 host.


When I start the qemu-system-i386.exe without arguments the qemu window opens and eventually halts due to no boot image.


Curious I wrote a simple script to start all the qemu-system-*.exe files in the distribution without any arguments. The results were mixed. Some of the qemu exes start a qemu window. Others write to the event log and the last group does not write anything to stdout or stderr.


Here is an example event log entry:


<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">


  <Provider Name="Application Error" />

  <EventID Qualifiers="0">1000</EventID>




  <TimeCreated SystemTime="2014-06-03T22:19:54.000000000Z" />




  <Security />













  <Data>c:\Program Files (x86)\qemu\qemu-system-moxiew.exe</Data>

  <Data>c:\Program Files (x86)\qemu\qemu-system-moxiew.exe</Data>





Thanks for your help,



reply via email to

[Prev in Thread] Current Thread [Next in Thread]