qemu-discuss
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] [SOLVED] Can't boot Debian netinst ISO


From: Richard Lewis
Subject: Re: [Qemu-discuss] [SOLVED] Can't boot Debian netinst ISO
Date: Fri, 28 Feb 2014 17:48:09 +0000
User-agent: Wanderlust/2.15.9 (Almost Unreal) SEMI-EPG/1.14.7 (Harue) FLIM/1.14.9 (Goj┼Ź) APEL/10.8 EasyPG/1.0.0 Emacs/24.3 (x86_64-pc-linux-gnu) MULE/6.0 (HANACHIRUSATO)

At Fri, 28 Feb 2014 14:49:08 +0000,
Richard Lewis wrote:

> I'm very new to QEMU. I have verion 1.1.2 from Debian stable
> installed. I'm logged into the guest system via SSH.
> 
> I'm trying to create a VM on which to install Debian. This is what
> I've done:
> 
> $ qemu-img create -f qcow2 debian-image.qcow 2G
> $ qemu-system-x86_64 -hda debian-image.qcow -cdrom 
> debian-testing-amd64-netinst.iso -boot d -m 512 -curses
> 
> When I do this I see a screen showing me:
> 
> ----------------------------------------------------------------------------
> 
>     640 x 480 Graphic mode
> 
> ----------------------------------------------------------------------------

So it seems that the ISO image *is* booting, it's just that I can't
see the installer on the terminal because it's in VGA mode. That's
presumably what the above screen was telling me. But my QEMU knowledge
was too deficient to know that.

I eventually managed to work out how to connect a VNC client to it:

host$ qemu-system-x86_64 -hda debian-image.qcow -cdrom 
debian-testing-amd64-netinst.iso -boot menu=on -m 512 -vnc :1

And then on my local X11 machine:

$ vncviewer host::5901

And I found the install menu waiting for me!

Richard



reply via email to

[Prev in Thread] Current Thread [Next in Thread]