[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] qemu: Error while loading ./foo.img: Exec format erro

From: Dunrong Huang
Subject: Re: [Qemu-discuss] qemu: Error while loading ./foo.img: Exec format error
Date: Fri, 29 Nov 2013 10:15:42 +0800

On Fri, Nov 29, 2013 at 1:03 AM, John Smith <address@hidden> wrote:

Im running a 32-bit VMware Linux (Fedora 19) guest/VM on a 64bit
Windows 7 host, with a Intel Core 2 Duo cpu.

Im trying to run qemu (version 1.4.2) in the linux vm, but I run into
the following error:

$ qemu-i386 ./cirros-0.3.0-i386-disk.img
Error while loading ./cirros-0.3.0-i386-disk.img: Exec format error
qemu-1386 is a user mode emulator, you should use qemu-system-i386 instead. 
PS, if your vm cpu has "vmx" flag(in /proc/cpuinfo), you can use "-enable-kvm" to get more performance.

I have tried images from multiple sources, but get the same results
with each image i tried. (for example, the linux-0.2.img.bz2 from

Any and all help is appreciated.


John Smith

Best Regards,

Dunrong Huang 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]