[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] how to disable VNC in qemu?

From: chronodekar
Subject: Re: [Qemu-discuss] how to disable VNC in qemu?
Date: Wed, 2 Oct 2013 13:40:13 +0530

Replying to group because it might be relevant,

I downloaded the current stable kernel release from kernel.org. (version 3.11.2). After extracting it I ran,

make menuconfig ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf-

I assure you that the CROSS_COMPILER is in the $PATH. Then I compiled the uImage with this command,

make ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- uImage LOADADDR=0x00008000 -s

The resulting uImage does NOT seem to boot with qemu (or I compiled qemu wrongly). Could I have got the LOADADDR wrong or something?


On Wed, Oct 2, 2013 at 11:53 AM, "Gábor, Wacha" <address@hidden> wrote:
Are you sure it is a problem with QEMU and not with your kernel?


2013-10-02 08:16 keltezéssel, chronodekar írta:
At first, I was unable to compile qemu with the sdl option. An error came up complaining about,

ERROR: User requested feature sdl
configure was not able to find it

Some internet searching led me to a stackoverflow question that suggested to install the sdl packages in ubuntu. I did that with this command,

sudo apt-get install libsdl-image1.2-dev

I was then able to compile qemu.

./configure --enable-sdl --target-list="arm-softmmu arm-linux-user"

 But running my image with this,

./qemu-1.6.0/arm-softmmu/qemu-system-arm -M versatilepb -sdl -m 128M -kernel linux-3.11.2/arch/arm/boot/uImage

Just pops up a blank/black window. I can close it - which means qemu closes properly instead of me killing the process, but I still don't see the kernel boot messages.

I'm beginning to wonder if I'm approaching the problem in the wrong manner. You see, I just want to see how an ARM system boots using qemu (and play around with the kernel and uboot). Are there any (updated) tutorials I could use?

ANY suggestions would be appreciated.


On Tue, Oct 1, 2013 at 8:46 PM, dE <address@hidden> wrote:
On 10/01/13 14:59, chronodekar wrote:
Thank you for replying dE.

I tried using gtk as below and get the following error,

> ./qemu-1.6.0/arm-softmmu/qemu-system-arm -M versatilepb -gtk -m 128M -kernel linux-3.11.2/arch/arm/boot/uImage
qemu-system-arm: -gtk: invalid option

Using curses like this,

./qemu-1.6.0/arm-softmmu/qemu-system-arm -M versatilepb -curses -m 128M -kernel linux-3.11.2/arch/arm/boot/uImage

Just makes my terminal window go blank and I don't see anything. My host system is ubuntu 12.04 (64-bit) 4GB RAM. I can understand if the simulation (or emulation?) is slow, but for nothing to appear for about 30 seconds makes me think something is wrong (I killed the qemu-system-arm process from another terminal window after that time period). Or should I wait longer?

As for not using the ubuntu package manager, I want to eventually try adding my own custom board to qemu - which means that I'd better start getting used to compiling the code. Note; I don't have any hardware and am using this as a way to learn more about ARM systems.

Off-topic: Do I use "reply-to-all" when responding or only reply to "qemu-discuss[at]nongnu.org" ? (am new to mailing lists)


The system that you're starting has menus in it, so that cant be displayed in ncurses mode. Try -sdl.

In x86 virtulization, we have these modes (-gtk, -sdl). There's no reason why they should not be available on other archs.

While compiling, check to see if youv'e enabled support for gtk and sdl (we do have these options according to Gentoo package manager).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]