[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] how to disable VNC in qemu?

From: chronodekar
Subject: Re: [Qemu-discuss] how to disable VNC in qemu?
Date: Tue, 1 Oct 2013 14:59:23 +0530

Thank you for replying dE.

I tried using gtk as below and get the following error,

> ./qemu-1.6.0/arm-softmmu/qemu-system-arm -M versatilepb -gtk -m 128M -kernel linux-3.11.2/arch/arm/boot/uImage
qemu-system-arm: -gtk: invalid option

Using curses like this,

./qemu-1.6.0/arm-softmmu/qemu-system-arm -M versatilepb -curses -m 128M -kernel linux-3.11.2/arch/arm/boot/uImage

Just makes my terminal window go blank and I don't see anything. My host system is ubuntu 12.04 (64-bit) 4GB RAM. I can understand if the simulation (or emulation?) is slow, but for nothing to appear for about 30 seconds makes me think something is wrong (I killed the qemu-system-arm process from another terminal window after that time period). Or should I wait longer?

As for not using the ubuntu package manager, I want to eventually try adding my own custom board to qemu - which means that I'd better start getting used to compiling the code. Note; I don't have any hardware and am using this as a way to learn more about ARM systems.

Off-topic: Do I use "reply-to-all" when responding or only reply to "qemu-discuss[at]nongnu.org" ? (am new to mailing lists)


On Tue, Oct 1, 2013 at 11:49 AM, dE <address@hidden> wrote:
On 10/01/13 11:47, chronodekar wrote:
Hello everyone,

I've been following the instructions on the following site to cross-compile the linux kernel, uboot and to run them off qemu.

The actual instructions on the site are rather old (they refer qemu version 0.14.0, while the latest is 1.6 - I think). I had to improvise on some of the instructions mentioned there. But the short version of events is this,

I downloaded version 1.6.0 of qemu sources from this site;

Then I built it using these commands,

./configure --target-list="arm-softmmu arm-linux-user"

I did NOT run "make install". Chances are, that I would be fiddling around with multiple versions and to keep things separate, want to be able to clean things up by deleting the top level source folder. Then, I built the linux kernel and tried running it with this command,

./qemu-1.6.0/arm-softmmu/qemu-system-arm -M versatilepb -m 128M -kernel linux-3.11.2/arch/arm/boot/uImage

The following came as output,

oss: Could not initialize DAC
oss: Failed to open `/dev/dsp'
oss: Reason: No such file or directory
oss: Could not initialize DAC
oss: Failed to open `/dev/dsp'
oss: Reason: No such file or directory
audio: Failed to create voice `lm4549.out'
VNC server running on `'

I was expecting to see messages from UART - the kernel boot stuff. Instead, it looks like qemu is opening up a VNC session (trying to connect to the above IP gives me a black non-responsive screen).

Does anyone know how I could avoid starting the VNC session and just see boot messages instead?


Try switches -gtk or -curses.

Why are you not using your distro's PM to install Qemu?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]