[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] Problem while emulating microcontroller

From: Muhammad Zaman
Subject: [Qemu-discuss] Problem while emulating microcontroller
Date: Sun, 14 Jul 2013 02:18:12 -0700 (PDT)


I am a newbie at using QEMU. I am trying to emulate the STM32f303 microcontroller on QEMU. I run QEMU with the command

qemu-system-arm -cpu cortex-m3 -s -m 513 -kernel stm32f3.elf
(stm32f3.elf is the binary file)

Then I start gdb and connect with QEMU. When I run backtrace it gives me an error saying

#0  0x0800106e in SetSysClock () at src/system_stm32f30x.c:313
#1  0x08000f3c in SystemInit () at src/system_stm32f30x.c:203
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

When I continue it gives seg fault and dumps core. Viewing the core with gdb gives

Program terminated with signal 6, Aborted.
#0  0xf7718430 in __kernel_vsyscall ()

Could anyone please help me with this problem. I have no idea why it is doing that. Another problem is that is seems unable to write values onto variables. There is a variable which is incremented in a loop, but when I view its value its not changing. Any help would be greatly appreciated. Thanks.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]