[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] GDB hangs at step of next command

From: Muhammad Zaman
Subject: [Qemu-discuss] GDB hangs at step of next command
Date: Thu, 4 Jul 2013 21:01:02 -0700 (PDT)

Hi all,

I am a newbie at using QEMU and working at virtualization in general. I am trying to emulate the STM32f303 microcontroller on QEMU. I run QEMU with the binary .elf file (stm32f3.elf) with the command

qemu-system-arm -cpu cortex-m3 -s -m 513 -kernel stm32f3.elf

Then I start GDB and connect with QEMU. When I run backtrace it gives me an error saying

#0  0x0800106e in SetSysClock () at src/system_stm32f30x.c:313
#1  0x08000f3c in SystemInit () at src/system_stm32f30x.c:203
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

So the line system_stm32f30x.c:313 is part of a do-while loop which adds 1 to a variable StartUpCounter. When I print its value it is 0 so it means that it hangs before going through the loop even once. And when I try the command step or next, GDB just hangs. Can anyone help me with this issue? Thanx.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]