[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] having TPM passthrough issues with Qemu

From: address@hidden
Subject: [Qemu-discuss] having TPM passthrough issues with Qemu
Date: Tue, 16 Apr 2013 11:34:16 -0700

I'm having issues getting TPM passthrough to work with Qemu. I'm using a relatively recent build (commit e0e367bad717...) on Centos 6.4 and passing it the --enable-kvm option when configuring. I have a working TPM on the machine which I have been using with the trousers package, and I have also tried using the TPM emulator from http://tpm-emulator.berlios.de/.

The command I am running is 'qemu-system-x86_64 -drive file=/var/lib/libvirt/images/Test.img -boot d -nographic -tpmdev passthrough,id=tpm0 -device tpm_tis,tpmdev=tpm0 -enable-kvm -nodefconfig -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x4'. I am able to get the system to boot normally when I have the TPM enabled on the host, but I'm not seeing a TPM device within the guest (Centos 6.4).

I have also tried running the same command when using the TPM emulator, but qemu silently fails (gives exit status -1).

My questions are:
1) Is there something I am doing wrong when I try to pass through the host TPM and/or has anyone else managed to get this working successfully?
2) Has anyone else tried to pass through an emulated TPM, and is this even supported? If not, are there plans to add support?    

reply via email to

[Prev in Thread] Current Thread [Next in Thread]