[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] Run arm-elf baremetal executable on qemu

From: Jay Aurabind
Subject: Re: [Qemu-discuss] Run arm-elf baremetal executable on qemu
Date: Thu, 21 Feb 2013 21:02:49 +0530

Oops, sorry for the typo, Its LPC2103 rather than PLC2103. Sorry,

Best Regards,
Jay Aurabind

On Thu, Feb 21, 2013 at 8:31 PM, Jay Aurabind <address@hidden> wrote:
Hello everybody,

I`m trying to execute a bare metal executable compiled (arm-elf). I`m getting segfaults. The command I used is: 

qemu-arm -L /opt/lpc2103 hello.elf

The error I get is :

qemu: uncaught target signal 11 (Segmentation fault) - core dumped
[1]    16858 segmentation fault  qemu-arm -L /opt/lpc2103 hello.elf

 The directory /opt/lpc2103 contains the toolchain installation. I also tried putting /opt/lpc2103/lib and /opt/lpc2103/lib64, which also gave the same error.

My target device is an ARM7TDMI-S processor from NXP (PLC2103)

What should be my next move?

Thanks in advance,
Jay Aurabind

reply via email to

[Prev in Thread] Current Thread [Next in Thread]