[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] PCI Device Assignments: One guest works, one doesn't

From: Greg Valcourt
Subject: [Qemu-discuss] PCI Device Assignments: One guest works, one doesn't
Date: Tue, 12 Feb 2013 19:56:20 -0600

I am attempting to assign a sound device to a guest. What I get in the logs is:

2013-02-12 03:47:55.189+0000: starting up
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin HOME=/ QEMU_AUDIO_DRV=none /usr/bin/kvm -S -M pc-1.1 -enable-kvm -m 4096 -smp 4,sockets=4,cores=1,threads=1 -name studio -uuid fbef058f-5555-6798-73c5-59f9fae1d678 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/studio.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/dev/kvm_guests/studio,if=none,id=drive-virtio-disk0,format=raw -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -drive if=none,id=drive-ide0-1-0,readonly=on,format=raw -device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=24,id=hostnet0 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:00:0c:00:00:03,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -vnc -vga cirrus -device pci-assign,host=05:06.0,id=hostdev0,configfd=25,bus=pci.0,addr=0x4 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6
char device redirected to /dev/pts/1
Failed to assign device "hostdev0" : Device or resource busy
*** The driver 'pci-stub' is occupying your device 0000:05:06.0.
*** You can try the following commands to free it:
*** $ echo "1412 1712" > /sys/bus/pci/drivers/pci-stub/new_id
*** $ echo "0000:05:06.0" > /sys/bus/pci/drivers/pci-stub/unbind
*** $ echo "0000:05:06.0" > /sys/bus/pci/drivers/pci-stub/bind
*** $ echo "1412 1712" > /sys/bus/pci/drivers/pci-stub/remove_id
kvm: -device pci-assign,host=05:06.0,id=hostdev0,configfd=25,bus=pci.0,addr=0x4: Device 'pci-assign' could not be initialized
2013-02-12 03:47:57.393+0000: shutting down

I've tried the echo commands, it just results in the same error (my previous experience tells me that this error message does not indicate the actual reason the device cannot be read from).

I have another guest with a graphics assignment that works: I'm passing through a Radeon 5770 to Windows guest just fine (well, it works as in it boots and displays on the intended monitor). My experience with this setup, is that the fglrx module could not be loaded while the guest was using the card, even though the driver was for a different card, and the guest's card was assign to pci-stub in initram. This tells me that the driver is doing something to the guest card, even though it is not bound to it.

So I decided to remove all sound modules from the host OS. That is done. But I still have this problem.

If passthrough works for one device on one guest, what is it I have to watch for if another device is not working with another guest?

BTW, I'm using virt-manager, so I usually assume that the drivers are being unbound properly from devices, and if I run into problems, then I issue the echo commands to free the devices (so far that has never worked).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]