[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] qemu 1.3.0 hangs on macos 10.8.2

From: cmason
Subject: [Qemu-discuss] qemu 1.3.0 hangs on macos 10.8.2
Date: Sun, 30 Dec 2012 22:36:50 -0800

I'm trying to get qemu working on my Mac running 10.8.2 so I can cross
compile compilers and various other things for the raspberry pi.  I've
followed instructions:


I've tried both qemu 1.1.0 and 1.3.0 using homebrew.  I've also tried
manually compiling 1.3.0 with clang (default cc) and with gcc-4.2.  I've
used the configure options:

./configure --disable-sdl --disable-kvm --enable-cocoa --cc=gcc-4.2

(I've also tried with standard clang cc.)

All of these combinations simply result in an empty white window when
launching the raspbian wheezy 2012-12-16 image and a kernel I compiled
locally (which boots on the teensy) using:

qemu-system-arm -M versatilepb -cpu arm1176 -m 256 -hda
raspberry-qemu.ext4 -kernel zImage -append "root=/dev/sda2" -serial

Figuring it might be something with this raspberry pi kernel or image,
I've also tried the exact debian squeeze image, initrd, and vmlinuz this
page claims to have working:

This results in 

> qemu-system-arm -nographic -M versatilepb -kernel vmlinuz-2.6.32-5-versatile 
> -initrd initrd.img-2.6.32-5-versatile -hda 
> debian_squeeze_armel_standard.qcow2 -append "root=/dev/sda1 console=ttyAMA0"
Uncompressing Linux... done, booting the kernel.
[Hangs, basically indefinitely; I've waited hours.]

Since this supposedly works for others, it must have something to do
with my setup but I can't figure out what it is.  I've read about folks
with similar white screen hanging problems due to clang, but as said
above, I've tried with gcc-4.2, and with the 1.3.0, which indicates it
works with clang anyway.

Any help would be most appreciated.


Here are the compilers version outputs:

gcc-4.2 -v
Using built-in specs.
Target: i686-apple-darwin11
Configured with:
--disable-checking --prefix=/usr --mandir=/share/man
--program-transform-name=/^[cg][^.-]*$/s/$/-4.2/ --with-slibdir=/usr/lib
--build=i686-apple-darwin11 --program-prefix=i686-apple-darwin11-
--host=x86_64-apple-darwin11 --target=i686-apple-darwin11
Thread model: posix
gcc version 4.2.1 (Apple Inc. build 5666) (dot 3)

cc -v
Apple clang version 4.1 (tags/Apple/clang-421.11.66) (based on LLVM
Target: x86_64-apple-darwin12.2.1
Thread model: posix

 gcc -v
Using built-in specs.
Target: i686-apple-darwin11
Configured with:
--disable-checking --enable-werror
--mandir=/share/man --enable-languages=c,objc,c++,obj-c++
--program-prefix=llvm- --program-transform-name=/^[cg][^.-]*$/s/$/-4.2/
--with-slibdir=/usr/lib --build=i686-apple-darwin11
--program-prefix=i686-apple-darwin11- --host=x86_64-apple-darwin11
Thread model: posix
gcc version 4.2.1 (Based on Apple Inc. build 5658) (LLVM build

qemu-system-arm --version
QEMU emulator version 1.3.0, Copyright (c) 2003-2008 Fabrice Bellard

reply via email to

[Prev in Thread] Current Thread [Next in Thread]