[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] Newer Builds Available for Ubuntu 12.04 LTS?

From: Mike Lovell
Subject: Re: [Qemu-discuss] Newer Builds Available for Ubuntu 12.04 LTS?
Date: Fri, 14 Dec 2012 18:01:27 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Thunderbird/17.0

On 12/14/2012 08:08 AM, Andrew Martin wrote:
I am running Libvirt 0.9.8 and QEMU 1.0 on Ubuntu 12.04 LTS on several virtual 
machine servers and would like to take advantage of some of the snapshotting 
functionality available in newer versions of QEMU and Libvirt:

Is anyone maintaining newer binary builds for Ubuntu? I was not able to find a 
PPA with updated packages, and building from source is proving rather tricky 
because my custom-built packages have some differences from the official 
packages (e.g. no upstart integration). I would really like to use the newer 
versions of Libvirt and QEMU on this LTS release.

there are newer builds of qemu and libvirt in the newer releases of ubuntu and so it may be possible to use those. https://help.ubuntu.com/community/PinningHowto gives some good information about how to either install a newer package version from a newer release (apt-pinning) or how to build a newer version ('recommended alternative to pinning'). the versions in the instructions are old but you should be able to just use precise and quantal where appropriate. i'm pretty sure that installing the quantal build of qemu-kvm through apt-pinning will just work. getting an updated libvirt might be a little more problematic due to possible changes in the apis for client applications. you may have to update any apps using libvirt as well.

i briefly tried to rebuild the quantal version of qemu-kvm (1.2) using the instructions on the PinningHowto on a 12.04 workstation. the quantal version has some additional build dependencies that didn't get fulfilled during the apt-get build-dep stage. you should be able to just install any packages it says are missing. on my system, i had to `sudo apt-get install libbluetooth-dev libbrlapi-dev libjpeg-dev xfslibs-dev` to get the necessary dependencies. the resulting .debs should just be in the current working directory that you can install through dpkg. i didn't test installing since i already have other custom things going on and i haven't tried rebuilding libvirt.

good luck.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]